• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

PC won't boot, d_ram led constantly shining

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

Serpent

New Member
Joined
May 4, 2020
Okay so, I had this same build for 5 years
Mobo: asus m5a99fx pro r2.0 gpu: gigabyte windforce r9 280x cpu : amd fx 8300 psu: super flower sf-650p14he 650W. Ram is two 4gb ram sticks (geil evo potenza pc3-12800 ddr3 using 1.5v) it was working fine until recently.
The first time booting the computer in a while I heard beeping and cpu fan error showed on screen, I have managed to fix this error (or i think i did) by renewing thermal paste and cleaning gunk/dust from the fan so it can work properly.
After that, the pc now will turn on but wont display anything, with dram led constantly shining in red. One long beep and two short ones can be heard (it said in the manual that its a ram problem, I have also noted that cpu led briefly lights up (for like half a second) whenever I press memOk button (might not be relevant but im not the best when it comes to parts so i thought i'd just put it here), but no display whatsoever.

what i tried:
*Removing ram sticks and trying them on different slots making sure they're prefectly placed, tried one ram stick at a time and did it all over again with no results.
* trying the memOk button over and over again
*removing the cmos battery to reset bios configuation
*reset the ram memory by moving the pin then putting it back just like it says in the manual
*removing gpu,cpu


I would really appreciate any help since this pc is my only means of entertainment especially in this pandemic lockdown. Thank you and sorry if this was long to read but I really need help.
 

trents

Senior Member
Joined
Dec 27, 2008
I would try removing the CPU from the socket and check for burnt, bent or contaminated pins. By contaminated I mean perhaps the thermal paste got onto pins or in the socket. Examine the pins under a bight light and also examine the socket.

Other possibilities are failed power producing components that supply the RAM such as mosfets or capacitors which may or may not show damage but examine those things on the board.

It is unlikely that both RAM sticks failed at the same time unless that is, they got too much juice from a failed power producing/regulating component.

Was the system overclocked?
 

CJustin

Registered
Joined
May 8, 2020
Have you checked the processor for damage?
It may be that the processor or the processor socket has been damaged.
Clear the dust off the RAM sticks by rubbing the RAM with an eraser.
That will remove dirt and moisture.

Tell us what the results are.