• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Peltier losing power

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

Chrisramseyer

Disabled
Joined
Dec 18, 2000
I have a peltier that is 122 watts and it use to cool my cpu below freezing and now it is + 22 . I have no idea what is going on. I took it off three weeks ago becouse of condensation and now it will not even cool that much. Any ideas, and yes:

I have cleaned they system,
have water,
have a radiator,
cleaned the peltier,water block and copper cold thing,
taken the dogs out and got the milk...
oh that is a different list.
 

Daniel ~

Senior Member
Joined
Dec 16, 2000
Location
Seattle Wa.
Chrisramseyer (Dec 29, 2000 03:32 p.m.):
I have a peltier that is 122 watts and it use to cool my cpu below freezing and now it is + 22 . I have no idea what is going on. I took it off three weeks ago becouse of condensation and now it will not even cool that much. Any ideas, and yes:

I have cleaned they system,
have water,
have a radiator,
cleaned the peltier,water block and copper cold thing,
taken the dogs out and got the milk...
oh that is a different list.

A shot in the dark: A damaged pelt or incorrectly attached water block. Or how about a air pocket in your lines. Actually I'm pretty clueless here":O{
 

Tim-

Senior Member
Joined
Dec 18, 2000
Location
North Carolina
A Peltier array is made up of many junctions- perhaps a voltage spike or something took out some of the junctions.