• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Problem Lenovo z51-70 amd r9 m375 drivers

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

Mercurius

New Member
Joined
Jun 18, 2020
Hello guys and sorry for disrupting you from your daily activities , i ecountered a problem today after i opened my laptop (lenovo z51-70 i5 5200-U , 8gb ,Intel HD 5500 and amd r9 m375 4gb).
So the problem is this : yesterday i wanted to install the latest drivers from amd (to crimson ReLive 17.7.1 from radeon crimson 16.10.1) what i did was that first i downloaded latest drivers for intel 5500 (version 15.40.45.5126) and after i installed it i used DDU in safe mode to clean uninstall the amd driver (picked first option in DDU , i made sure that i checked amd drivers to be uninstalled), after that i installed amd catalyst 15.11.1 Beta (to get all the settings available),everything worked good , laptop restarted without any problems and i thought there was no problems whatsoever , until i opened google chrome ,here i realised that the words i was typing werent visible but they were written but after i tried to hit enter everything would fall apart my screen would froze , couldn't do anything and when i tried to press Ctrl+Alt+Delete then my screen would turn black and nothing would've solve it other than a restart , so i decided to turn back to my old drivers (crimson 16.10.1) , i restarted in safe mode used DDU for amd then restarted in normal mode and installed it . Everything was working good , then i decided to go into intel graphicss properties and adjust display , the only thing that i changed in it was ''quantization range'' to full range for a deeper colour , everything seemed to look fine until this morning , i opened my laptop and the first thing that i did i tried to open WOT , it started and after a couple os seconds my screen flicker one time then in the start bar it gave me a message that the driver failed and it was able to recover , i started WOT again but the problem was that from normal 100-120 fps on it , it was playing at 40-60 fps range , i noticed it went to dextop and right click on mouse to try and go to amd panel but there was only 1 amd panel instead of 2 (1: to change to switchable graphics the programs/games i was running ; 2: the usual amd catalyst with other settings like ) the gpu one disappeared and when i went to the regular one theres was nothing other than display resolution and video watching settings.
So i decided to restart computer in safe mode and this time use the 17.4.4 version , i went into safe mode used DDU restarted the computer and when i got back into the windows and tried to install the driver it would give me this error: ''Error 173 - Radeon Software Install cannot proceed as no AMD graphics hardware has been detected in your system configuration'' , after this i tried my old driver and the 17.7.1 but all of them would say the same thing , if i go to device manager to display adapters the only thing there would be the Intel HD 5500 , i checked show hidden devices , scan for hardware changes but with no success.
I even downloaded the amd uninstall program to try to see if it gets the job done but since i used the DDU there was nothing left to unistall , i went to BIOS aswell and made sure the switchable graphics is on and it was , i even checked the windows update to see if i get any update for my problem but with no success.
One thing that i forgot to metion earlier i use a HDMI cable to a 4k monitor(6102 Samsung UHD) but i'm using ''duplicate this displays'' so i can use 1920x1080 and today i encountered at the same time a purple stain appeared in top right corner on the TV screen , does that mean my GPU chipset its fried/dead ? Is there anything that i can do to fix this problem? Can anyone help me with this problem please?.
 

trents

Senior Member
Joined
Dec 27, 2008
Is English your first language? Your description of the problem and your troubleshooting measures are very hard to follow because the second paragraph is one big "run on" (run together) sentence.

Does your laptop use dual GPUs (an Intel IGP and a dedicated AMD video chip)?

I think you should back up your data and do a clean install of Windows. Windows 10 probably has native drivers for bot GPUs.
 
OP
M

Mercurius

New Member
Joined
Jun 18, 2020
Sorry for the confusion created , English is my second language , yes my laptop uses dual GPUs integrated intel and amd chipset.
Forgot to specify in the first comment i'm using windows 8.1 x64 , there aren't any other options other than installing a clean windows? Just asking before making a decision .
Thanks for supporting me on this matter!.
 

trents

Senior Member
Joined
Dec 27, 2008
So, I'm guessing what is happening is that the switching that should be happening when you game from the Intel GPU to the AMD GPU isn't happening. Maybe that's why your FPS was cut in half.

One thing could try is rolling back the system to an earlier date before the problem started by using Windows Restore. In the search window, type "Create a Restore Point" to get there. Now, you really aren't going to create a restore point but that would take you to the Restore tool where you can choose a restore point from the ones already having been created. This is assuming that tool was not disabled.
 
OP
M

Mercurius

New Member
Joined
Jun 18, 2020
My apologies for the lengthy delay in responding. I have Restore Point enabled but there no saves of an earlier point in it
Today for some reason i tried once again to figure out any solutions , i noticed in Ccleaner while trying to perform a Clean Registry that the AMD driver would popup in multiple instances but w/o luck
I guess the only option available right now is to clean install a new Win and see from there if the problem persists well.... yeah hopefully it won't be the case.

If there are any step(s) you know that are worth trying i would gladly try them out.

Thank you in advance , wish you have an wonderful day/night!