• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Problem with TT case light

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

WellSheit

Disabled
Joined
Nov 20, 2002
Location
alabama
i got a thermaltake 12" cathode case light. put it in and all seemed fine, but i noticed when i turned it on, the fan seemed to drop in rpm's a bit. then, after a while (a few hours), everytime i'd turn on the light while the pc was running, it would turn off. the fans would continue to run, but it would shut off and the monitor wouldn't even show anything. as soon as i turned the light off, the computer will restart. i know it cant be a shortage of power, b/c i unplugged both cd drives, both hdd's, and the floppy, and all i had plugged in was the dragon orb pcu fan and the light. i still received the same result even with JUST these 2 things plugged in. i dont know what the problem is or if something is wired wrong of if something is wrong with the light. its a mess :( also..the switch for the light doesn't have a ground, so that can't be the problem. please help
 
OP
W

WellSheit

Disabled
Joined
Nov 20, 2002
Location
alabama
i have a turbolink 420W psu that came with my chieftec case....and im running an amd 1.1 ghz processor.....mobo is an asus a7v333
i dont think its the psu, b/c as i said...even with just the dragon orb 3 and light hooked up and no other power cords connected, i still had the same result
 

obliv

Member
Joined
Jul 14, 2002
then that very well could be a psu problem, check your +12v line voltage, i bet its so low that its not able to feed enough power to every component (even 2). Or you can try a new cathode, but no cathode has the power to do that (imo)
 

obliv

Member
Joined
Jul 14, 2002
what if you don't use the light and connect all other power sources? is the computer stable then?
 
OP
W

WellSheit

Disabled
Joined
Nov 20, 2002
Location
alabama
yes very

computer runs 1.1 amd ghz processor, 7000rpm dragon orb 3, floppy, dvd drive, cd rw, 2 hdd's, 3 case fans, the asus mobo, the nic, audigy gamer sound card, gf2 vid card.....it all runs perfect and with a creamery goodness...but then if i reach around and hit the light switch.....im blinded by light...but my computer is shut down...but the fans continue to run ? if i turn the switch off.....my computer restarts.....its kinda scary :confused: