• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

SOLVED R9 280 OC doesn't work for 3D MARK

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.


New Member
Dec 24, 2014
Hi OC's!

My current system:
CPU: FX-8350 4.4GHz
GPU: R9 280 OC 3GB
RAM: 16GB Corsair Vengance Black
MB: Gigabyte GA-990FXA-UD3
PSU: 850W corsair HX850W
SSD: 60GB OCZ vertex 3
HDD: 2TB WB Green for media and 500GB WD Black for gaming

Problem: I am trying to OC my GPU, which has stock 950MHz clock and 1150MHz ram, while 1070MHz and 1250MHz in OC mode. I am trying to run 3D MARK Fire Strike benchmark but my GPU is stuck at stock values. I tried OC with CCC GPU OverDrive, MSI Afterburner but no performace increase was given. Even when all OC is of and GPU runs at stock rates I get 6700 score while with any kind of OC I get just 6000-6200 score. What the hek? I also got into MB's bios, boosted ram to 1866MHz, forced CPU to 4.4 GHz. Am i missing something or what?

Working res is 1920x1200
Last edited: