• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

R9 380 Issues

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

de_yogurt

Member
Joined
Nov 24, 2006
I just purchased an R9 380. Love the card, I am finally able to game at 1080p. I have only used it for BO3 so far. The problem is that I get going, the first 2 games run very well and then out of nowhere I get a stuttering problem. I do not have vsync turned on but I have the frames limited to 60. It almost seems that there is a heat issue but it could also be a driver issue. Are there any stable drivers for this card for BO3? The Catalyst 15.11.1 drivers were great but would cause the game to hang on a black screen. I'm new to the AMD video card scene, but its tempting to go back to Nvidia if the driver support is going to be this poor. Any ideas or thoughts are gladly welcomed. Thanks and have a good one!

Yogurt
 

EarthDog

Gulper Nozzle Co-Owner
Joined
Dec 15, 2008
Location
Buckeyes!
Did you try a different driver? Newer or older?

Did you check temperatures when it was stuttering? Have MSI AB running while you play the game... when the stuttering occurs, go look at the graph and see if clocks dropped, or vram limit was hit, or temps etc.......
 
OP
D

de_yogurt

Member
Joined
Nov 24, 2006
I have tried a few different drivers, newer and older. The old catalyst drivers seem to provide the best experience but they cause the game to crash. I should install MSI AB. I don't think the vram limit would be hit, I'm running high on all the settings but things like ambient occlusion, order transparency, etc, etc, disabled. I did read somewhere that the new drivers aren't keeping the core clock where it should be or it is displaying that information wrong. I'll have to check out MSI AB to see if I can narrow down the problem.
 
OP
D

de_yogurt

Member
Joined
Nov 24, 2006
Well, I found the issue at least in BO3. If you have the "Target Framerate" in the settings, set higher than the game (60FPS) it causes issues. As far as anything else goes, the GPU goes from 100% usage back down to 0% and anywhere in between.