• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Raid 1 - Need help rebuilding raid

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

FishFloat

New Member
Joined
Aug 6, 2022
Hi
I have a Raid PCI card "ST Lab PCIe SATA 6G Raid card 4channel" and 4 disks connected to it.
I'm running raid 1 on two of these with 2 x "16TB Toshiba Enterprise MG08 Series MG08ACA16TE 7200RPM 512MB Ent".
The disk are new and have worked for 4 days then I got an alarm in Marvell tray and the log says:
Info 0 PD Event 08/06/2022 08:02 Physical disk 0 is plugged in
Warning 0 VD Event 08/06/2022 08:02 Virtual Disk 0 is degraded
Warning 0 PD Event 08/06/2022 08:02 Physical disk 0 is unplugged

I did not un-plugg the disk but now I have a raid that is degraded. I checked the SATA cables and they look alright and are connected properly.

My first thought was to just rebuild, but I have never rebuild an raid before.
How does the rebuild work, does it take one of the disk and writes to the other or does it completely wipe both disk? (I have not a third disk with the same stuff!)
Will I lose data if I rebuild?
Both disk shows upp in Windows and from what I can see, both disk have the same info on them.

Best regards,
F

 

WhitehawkEQ

Premium Member
Joined
Dec 6, 2010
That's the nice thing about Raid 1, if 1 disk goes bad you can get a new disk and pop it in and all data on the other disk will be copied over to the new disk.
The rebuild is automatic, start with taking disk 0 out, wait a min then plug it back in, it will automatically rebuild disk 0 from disk 1, it that don't work you have a bad disk 0, get a new disk and plug it in.
 
OP
F

FishFloat

New Member
Joined
Aug 6, 2022
Hi and thanks for your reply.

marvell_raid.png

I'm thinking if disk1 was "broken", will the raid rebuild from both d1->d0 as well as d0->d1. Must the disk be empty for rebuilding?
Anyway I just checked in Windows both have the same information, checked with freefilesync.
I wonder why it didn't rebuild automatically when it was "plugged in" again as stated in the log?

Thanks for your quick reply
Best regards,
F
 
OP
F

FishFloat

New Member
Joined
Aug 6, 2022
Hi....so I tried to un-plugg disk 0 and then put it back again, nothing happened. So I tried to do the same for disk 1, still nothing happens.
I guess I need to select one of the virtual disks for rebuild.