• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Samsung 960 Pro m.2 Firmware Update

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.


Apr 29, 2017
Evening everyone,

I am trying to update the firmware of my 512GB m.2 960 Pro but so far unsuccessfully. Samsung Magician 5.1 software doesn't work on my computer. It installs OK, then the program asks me if I wanted to start it, then nothing happens apart from seeing its icon in the system tray. Double clicking, right click both do nothing. I can only kill it by task manager. Since the program has the habit to start itself upon reboot, I (sometimes) get the message it couldn't be started (click OK to try again, or cancel to close it). I tried with 4.96 and 4.92 versions, they both install and open normally but work for benchmark only and no other data, including firmware update. They just say N/A or are grayed out.

I've seen an iso-file on the Samsung 960 Pro website, tried making it bootable on a USB but for some reason it couldn't be read after POST. This is my first m.2 after some SSDs so I am unsure what I am doing wrong. Samsung NVMe driver in Windows 10 is installed and operational. The drive boots up OK and has the advertised speeds but I would like to have the option to keep an eye on it over time with all data handy and make updates easily. Anyone faced similar issues? Shall I install it on another drive? The m.2 is the current boot (C) drive.

There are some reports that Samsung Magician doesn't work with certain branded equipment, i.e. not associated with Samsung, but my drive is definitely a 960 Pro bought from Samsung so I do not see a reason why I shall be affected. Many thanks.
what mb etc... are you running?

I am still upgrading but am more or less in the final stage:

Rampage V Edition 10 X99 motherboard
Intel 6850K CPU (soon to be 6950X, when price-to-performance ratio becomes feasible)
Corsair Vengeance 32GB RAM at 3200MHz
Samsung 960 Pro 512GB m.2 boot drive
Intel 750 1.2TB u.2 drive
2TB Seagate HDD
Graphics card (to be upgraded to 1080Ti in the next weeks), GTX 560Ti
Xonar Essence STX audio card (to be upgraded to STX II)
Corsair 650D case
Windows 10 x64

I suppose the Samsung Magician problem is bound to some driver. The Samsung NVMe storage controller is installed and reports no problems. In addition, I have the Microsoft Storage Spaces controller, the Intel P3700/P3600/P3500/P3520/750 series driver, and the Intel C600+/C220+ series chipset SATA AHCI controller, all working OK. I don't understand why the GUI of previous Samsung Magician versions appears after program installation, and the newest one eventually starts with "collecting data" or something and then stays in the tray no matter what. Even if I right click nothing happens. Could it be that it is installed on the same boot drive or could it be related to version of .NET or Microsoft Visual C++? No messages or errors are received whatsoever.

By the way, I can see you have the same CPU as mine. How do you cool it? It is about 25 degrees (Celsius) in my room now and I am using the Scythe Mugen PCGH Edition air cooler. CPU core temperatures are at 39/40 degrees (Celsius) but the CPU package temperature is 58/59 as reported by HWiNFO64, Corsair Link reports about 4 degrees less. All above at idle. I've been reading the 6850K is quite hot by default, I haven't overclocked mine yet and will most probably not go for liquid cooling. The Scythe cooler has kept temps below 76 degress Celsius at 4GHz (Asus Turbo on) in CineBench but what concerns me is the idle CPU package temperature which I find pretty high. And I am sure thermal compound is OK as I tried with another air cooler and it showed similar results.
Pretty sure samsung magician works on my mobo (same as yours)...latest bios? Chipset and Ime drivers???

Idle temps arent terribly relevant, how about load temps. ;).
Pretty sure samsung magician works on my mobo (same as yours)...latest bios? Chipset and Ime drivers???

Idle temps arent terribly relevant, how about load temps. ;).

I have no clue why I can't see the program functioning. Just checked Event Viewer and couldn't see any app errors also. Latest BIOS and all drivers installed. Device manager doesn't report any errors also. I still believe it must be something driver-related since older versions of Magician install OK and I can start their GUI OK but they don't give me access to anything apart from benchmarking (at least the program sees all drives). I installed and uninstalled Samsung Magician many times (cleaning waste), still the same, unless some registry values stay no matter if the program is uninstalled.

Is it possible to check if the process is 32 bit on your PC? I also tried changing program's Security permissions giving access to all, still the same - it starts and goes into the system tray and no matter if I right or double click, it stays like frozen there, until I kill it via Task Manager. I attach a few screenshots from Task Manager and the program's .exe screens.
STM.jpg SM.jpg SM2.jpg

Load temps on my 6850K are below 76 degrees Celsius but with GTX 560Ti currently (CineBench, RealBench and some others). I will want to see how this changes with 1080Ti very soon. I still think however that idle CPU package temperature of 54-57 degrees Celsius is too high (CPU cores 41-43 degrees).
would bet it is the version of magician that isnt working. had that issue on mine at one time