• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Screen tearing fix I came about. Windowed Borderless vs. Fullscreen

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

HANDxOFxGOD

Registered
Joined
Oct 29, 2014
Ok, so here goes.

Well, I had awful screen tearing issues with a couple games for awhile. I would get screen tearing in Shadow of Mordor, Titanfall, and Dragon Age: Inquisition. I would do everything from V-Sync, Adaptive V-Sync, triple buffering, etc. and systematical turn on and off and the others on and off and every combination between in game and the nvidia control panel. I would still get screen tearing whether using a 120 Hz 42" 1080p TV or when using my recently acquired overclockable 1440p monitor.

My hardware consists of some pretty high end 'budget' parts. i5-3570k, MSI GTX 970, Asrock z77 Extreme 4, 8 gb ballistix ddr3, etc...

The other day I came across a fix that solved all of my problems. It was to simply put these games in windowed borderless as opposed to fullscreen. It simply worked wonders. Whether V-sync is on or off now, it doesn't matter. It's just buttery smooth.

Does anybody have any insight into why this worked?
I still don't get it and the internet is kind of devoid with any rational conversation about fullscreen vs. borderless window. I'd appreciate any replies.

Also, if you have screen tearing problems, just try the fix I mentioned... it's really amazing how easily my screen tearing went away with it.
 

sobe

Unscathed Member
Joined
Jun 22, 2005
I'll start off by saying that your tv is NOT 120Hz. It is 60Hz using software to manipulate a fake 120Hz setup, without getting into detail, it's just 60Hz like every other tv out there. Part of why I hate gaming on tv sets... The lag is horrid and marketing kills peoples' wallets like no tomorrow.

Onto the tearing, that will happen when your vid card/setup pushes more frames than the monitor can display and the monitor is trying it's hardest and fastest to display what it can, but at the end of the day it is stuck trying to display two or more frames at once during a single screen draw which is seen as tearing. Your tv being 60Hz only has around 59/60 fps to display, so capping your fps at 60 or using vsync will solve the tearing. (Going to a 120Hz or 144Hz monitor will minimize tearing, but if you start pushing more FPS than the monitor can handle then you are back at the tearing issue unless you cap your fps)


For windowed vs fullscreen, there are so many discussions it is insane. A simple google search of "windowed vs fullscreen" will bring up plenty. The gist of it is basically that full screen puts your system's resources into the game whereas in windowed your system is not placing priority on the game and instead on everything in the "background".

Hope that made sense. I know plenty who prefer to run windowed simply for faster alt tabbing, for me it depends on the game.
 
OP
HANDxOFxGOD

HANDxOFxGOD

Registered
Joined
Oct 29, 2014
I understand where you're coming from and I know how screen tearing works. That's exactly why I was perplexed. I was getting tearing on my overclock able QNIX 1440p monitor. I would be playing Shadow of Mordor getting around 50 frames per second on my QNIX that I have over clocked at 96 Hz. That didn't make sense. No matter my framerate, I would get tearing. The QNIX refresh rate is well above the FPS I can get out of Shadow of Mordor or Dragon Age... but the tearing was still there. (I was using FRAPS to determine frame rate)

In addition, I don't think that's the benefit of full screen... especially because you can still have downloads and other things going in the background that can still limit system resources.

What I am saying is that V sync was useless in full screen.. and now that I'm using borderless, the tearing is gone... V-Sync doesn't change anything either way... other than lowering FPS.
 

sobe

Unscathed Member
Joined
Jun 22, 2005
Hmm, with the QNIX doing it I'll admit that's a bit strange. I didn't have that issue with my QNIX even running SLI :/ That would drive me insane.

I don't mean that all other system services stop by any means, but if you play full screen then alt-tab, that second it takes to alt tab out vs playing windowed? That's indication of resources being allocated.

And again, odd that vsync didn't work at all, and once more, that would drive me insane, lol. I suppose if it's working in windowed though.
 
OP
HANDxOFxGOD

HANDxOFxGOD

Registered
Joined
Oct 29, 2014
ha. Yes, exactly. It drove me insane for about a month and then that Borderless vs. Fullscreen issue totally fixed it for me. I'm just curious to know why. Nobody ever suggested it. All people ever talk about is buffering and v sync and adaptive vsync, etc, etc...

I'm so happy I figured it out though... this 1440p monitor is bliss and now I have 0 issues.

LONG LIVE PC GAMING
 

motherboard1

Member
Joined
Jan 7, 2006
I have the exact same issue, some games are hard to look at while turning in spite of good frame rates. I accidentally discovered that Windowed mode eliminated the issue in Wolfenstien TNO, and that's how I played it from then on. I don't know if it's tearing or pacing, but Windowed was the way to go.
 

sobe

Unscathed Member
Joined
Jun 22, 2005
ha. Yes, exactly. It drove me insane for about a month and then that Borderless vs. Fullscreen issue totally fixed it for me. I'm just curious to know why. Nobody ever suggested it. All people ever talk about is buffering and v sync and adaptive vsync, etc, etc...

I'm so happy I figured it out though... this 1440p monitor is bliss and now I have 0 issues.

LONG LIVE PC GAMING

Just realized something, do you have Shadowplay enabled? Open up GeForce Experience and click on the Shadowplay button, then the "power switch" button to turn Shadowplay off completely. While I like Shadowplay, it is a mixed bag for different people/systems.
 

motherboard1

Member
Joined
Jan 7, 2006
I'm on AMD, No Geforce experience to speak of. I had a theory it was my processor choking that was causing weird frame pacing issues, My GPU never seams to max out in these situations. But now that some games improve on windowed mode, I don't know how that plays into it.
 

hajalie24

Member
Joined
Jun 20, 2008
Location
Michigan
Windows automatically handles vsync for you and all windowed apps, which is why you don't get tearing on your desktop and while using your browser, etc. When you go windowed everything it gets treated like how every other app gets treated so vsync is applied.

And despite what a lot of people say, tearing definitely happens happens at any framerate, even 60.


Screen tearing is all dependent on when your GPU decides to display the frame versus when your monitor decides to refresh. At 60 fps, if your GPU is displaying the frame halfway between each display refresh it's going to end up finishing at halfway between the next frame and the frame after. No matter what you're always going to have 2 frames in one screen draw with 60 fps, unless you sync the GPU frame draw and display screen draw are synced, hence why vsync is needed.
 

sobe

Unscathed Member
Joined
Jun 22, 2005
I'm on AMD, No Geforce experience to speak of. I had a theory it was my processor choking that was causing weird frame pacing issues, My GPU never seams to max out in these situations. But now that some games improve on windowed mode, I don't know how that plays into it.

I was referring to HANDxOFxGOD, but merely as a possibility. RadeonPro has helped AMD users with issues by capping fps.
 
OP
HANDxOFxGOD

HANDxOFxGOD

Registered
Joined
Oct 29, 2014
I'm not sure what you're talking about because that's definitely not the issue I was having. I was using FRAPS to check my frame rate. In Full Screen mode, I'd be getting tearing everywhere from 40-60 frames per second in Shadow of Mordor.

When I used Windowed Borderless, I'd still be getting between 40-60 frames per second.. but there was no tearing.

The same for DA: Inquisition. It's not turning V-Sync on in windowed mode. My frame rate still fluctuates.