• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Serious Issue Can't Play Certain Games @1920x1080p

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

AngelfireUk83

Member
Joined
Nov 7, 2004
I just tried playing Sonic All Stars Racing Transformed and Dead Space 3 but I am having issues with resolution I was using the latest crimson 16.7.2 hotfix and I've had no issues with games but these 2 (so far) just won't play properly Sonic the main menu just all corrupted that I can hear options being selected but can't see them but Dead Space loads the menu itself but when it does all that crap where the arm grabs the ice block and moves it over it doesn't show it's like it's zoomed in far to much. In DS3 I can see through the characters and doors there's no walls at all and I can see enemies etc WTF is going on I've even downgraded to 15.12's to see if that was an issue and I've removed Vulkan but it still work correctly.

I have been playing on my new ACER 24" monitor that can output [email protected] and other games work fine just tried Mass Effect 3 and that works ok Warhammer Space Marine 40k works fine I am wondering if it's an aspect ratio issue there's no 1920x1080p wide option in Dead Space 3 or Sonic
 

Johan45

Benching Team Leader Super Moderator
Joined
Dec 19, 2012
I don't think it's a resolution issue. I played through DS3 on a 1080p monitor without issue a while back.
 
OP
AngelfireUk83

AngelfireUk83

Member
Joined
Nov 7, 2004
I did the text file mod and the game plays now in the higher resolution but I don't get it because when I used to have my LG 32" HDTV as my gaming monitor it would play at that resolution no issues ???