• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Since changing my Router my Canon MX870 printer prints "blank" pages?

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

Shaitan000

Registered
Joined
Jun 30, 2008
For years now I've had a Canon MX870 printer (WIFI) connected to my Linksys EA4500 router which allowed me to print from various WIRED and WIRELESS computers/laptops without any issues (PDF, DOC, DOCX, word, chrome, etc...); and with home schooling during COVID-19 this was used a lot ...

Recently (last week) I purchased a new router (Asus RT-AX88U) to help improve the WIFI in my home (virtual classes in the kids rooms) but there is an unforeseen side-effect; none of my computers/laptops can print as they could before .... the printer gets the request and prints the number of pages expected AND it sounds like it is printing BUT the pages all come out BLANK each time.
- All computers are Windows 10
- I've added/removed the printer under Windows
- I've downloaded the latest Canon drivers (which installed some new thing) and this finds the printer succesfully
I am "sometimes" able to print when I use the CTRL-SHIFT-P command (which is odd! so not an ink issue) but not when I use the PRINT function in the application (Word, Chrome, etc...)

During the WIFI connection the printer had issues (it kept cycling between connected/disconnected) until I rebooted it and the router; and ever after that I couldn't complete the normal WIFI setup (with SSID/Password) as it failed each time, so in the end I had to use the WPS method (which worked perfectly).

I've taken a FRESH laptop (never connected to the printer before), loaded the drivers from Canon, and am having the exact same problem ... makes no sense to me how a new ROUTER could be causing this or how to resolved it?

Any suggestions would be welcome at this point...
 

Johan45

Benching Team Leader Super Moderator
Joined
Dec 19, 2012
I know it's not quite the same but after I swapped routers I had issues with my Cannon MX 882. I kept getting printer offline messages and similar. Installing the Cannon Network Tool on the PC worked for me.
 
OP
S

Shaitan000

Registered
Joined
Jun 30, 2008
I know it's not quite the same but after I swapped routers I had issues with my Cannon MX 882. I kept getting printer offline messages and similar. Installing the Cannon Network Tool on the PC worked for me.

Thanks! I had to install that regardless for the printer to work - that was another oddity as it used to be plug-and-play (never needed this Network Tool before) but without it I couldn't even connect anymore - so I install that and it sees the printer an loads it fine - which is why I can send print commands and the paper comes out ... but its BLANK..
 

Johan45

Benching Team Leader Super Moderator
Joined
Dec 19, 2012
I did a quick Google search and that seems to be a fairly common but unexplained phenomenon with the Canon printers although none of it seems to be network related like your case here.
 

Johan45

Benching Team Leader Super Moderator
Joined
Dec 19, 2012
Not sure what to do TBH, but you might just have to update the printer. I wondered on my end if it just has trouble with the newer wifi and the internal chip is just outdated. Is there any way you could wire it to the router or similar?
 

trents

Senior Member
Joined
Dec 27, 2008
You might also try connecting it via USB to one of the PCs on the network and configuring things to make it available to others on the network. The only issue there would be that the host computer would need to be left on.
 

habbajabba

Member
Joined
Oct 29, 2005
Location
Oregon
I have the 86U, 2 of them. I do not use any of the QoS or antivirus stuff that comes with the router as they require your router to be connected to someone else's server in order for that junk to even work. They want your router to be middle-manned which I will never allow. Plus I'm using the latest asus-merlin bios firmware. Sounds like a win10 issue really. My suggestion is to see if a simple usb connection to the printer solves the network printing issues. My xerox b205 has it's own web browser configuration page, the cannon doesn't and it's manuals are 10yrs old!
From this site:
https://community.usa.canon.com/t5/Printer-Multifunction-Support/Windows-10-and-MX870/td-p/147857
"After much troubleshooting and working with other network printers, the problem lay in Windows 10 changing my network settings. Once joined to the Home Group again and a firmware update on the wired router, all is well."
and
"I couldn't connect to canon mx870 after buying a surface pro with windows 10. After I change the usegroup to homegroup from workgroup, then it seems to work."