• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Skylake Windows 7 cant install

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

Neuromancer

Member
Joined
Oct 11, 2005
Location
Tau'ri
USB KB/M works in bios but not during install of windows 7.

I checked Legacy devices and tried a USB to PS2 connector I have hit default setting a couple of times. no joy so far. I get to windows 7 screen(installation where you select language, keyboard etc) and cant do anything.

ECS H110 ITX mobo (the cheapest one on newegg)
skylake 6100
2400 MHz DDR4. (actually running at 2133 cuz there are no XMP settings I can find)
Mushkin 480GB SSD


I am missing something I am sure. Any tips would be great. Thanks
 

[email protected]

Member
Joined
Apr 7, 2016
Location
Israel
Did you turn the Allow Win7 install setting in the BIOS?
I know my mobo has this setting so you should check if you have it too, Its in the boot tab.
 

mackerel

Member
Joined
Mar 7, 2008
Like [email protected] says, some bioses have a Win7 install setting which can help.
Try using USB2 ports not USB3 ones if available.
There are some USB3 driver modifications for Win7 install images, although I think they're aimed at the low power SOCs not desktop chipsets but you can research that too.
 

EarthDog

Gulper Nozzle Co-Owner
Joined
Dec 15, 2008
Location
Buckeyes!
Yup.. there should be an option in the bios, or you need to slipstream xhci drivers in your install. Most major makers have instructions on the boards webpage... check ecs webpage...or use msi smart tool to create install media.

Usb2 vs usb3 is not the issue.

As far as memory speed, you bought a h110 chipset, you cannot overclock it at all, even xmp, so you are stuck at 2133.
 
Last edited:
OP
Neuromancer

Neuromancer

Member
Joined
Oct 11, 2005
Location
Tau'ri
Thanks guys. I tried setting windows 7 in BIOS, USB legacy mode etc etc.

Trying to slipstream xhci drivers now and hopefully that will work