• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Sudden USB issues

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.


Jun 16, 2020
I have an ROG Strix B550-f Gaming board and just started to have severe USB issues on all ports. I've read back in the spring and summer about the USB connectivity issues plaquing the B550 and 570 boards, but I never had an issue. I'm on the current BIOS which was suppose to fix the issue and tried all other BIOS settings to rectify, but nothing.

I'll plug in a USB stick and it will work for 30seconds, disconnect and windows throws an error saying something is wrong with the USB. It will not work again until I reboot the computer.

I have an external SATA that isn't working either, and even if I plug in my XBOX controller it shows up in Device manager, but will not power on.

I tried a PCIe USB card thinking it was the USB"s on the motherboard, but I'm having the exact same issue, if not worse. I also noticed when I disable the onboard USB ports, it also disables blue tooth. Should this be the case?

I tried a fresh install of Windows with the same result. Any ideas? Is the board toast? Everything else works great, no blue screens or anything. Is it possible it's the PSU? Not enough power suddenly?

Ryzen 3700x
ROG Strix B550-F Gaming Wifi
32gb DDR4 3600
Radeon 5700xt
Corsair 850W PSU

Any help would be really appreciated!

I should add that most of my devices are on a powered USB hub, but plugging directly into the PC causes the same problems.

In doing some more troubleshooting, it looks like the issue is worse off the new PCIe card.

All devices are plugged into a powered USB hub, but I found the following.

Xbox controller or mouse do not work when the hub is plugged into the PCIe card. Mouse also randomly freezes when wireless.

The controller and mouse work fine when plugged into the hub from the onboard USB ports.

Is it possible that the PSU isn't cutting now that the issue seems work when it has to power the PCIe USB card?

All components are about a year old, except for the PSU which is a good 10 years. To my understanding 850W is more then enough to power this. I'd just hate to throw money at a new PSU and have it do the same thing. I'd also hate to replace the motherboard and have it be the PSU. :)

Again, everything else works great. I've never had a single issue with any games, and the PC doesn't even blue screen.
The 850W rating of a power supply has nothing to do with USB... USB isnt run off the 12V rail, but runs in 5VSB IIRC. What exact corsair power supply do you have? If it's 10 years old, it's time to replace it anyway. ;)

Sadly, there's no way to test without swapping out parts though. That said, I dont imagine it to be your motherboard because you tested with a pcie USB card...this does the hub connect power?
Thanks, I wasn't aware the USB doesn't draw power from the PSU. It's a Corsair AX850. It's atleast 8 years old. I guess I should replace it!

The USB hub was plugged into the PCIe card, but the problem was much worse so I moved it back to the onboard ports. The only device using the onboard USB ports is the hub itself.
Interesting enough, I've been doing large file transfers to multiple USB devices this afternoon without a single issue.

Now what??
Been playing around all afternoon, and now sometimes the computer won't detect a USB stick but it shows up under devices and printers to safely remove - but not in device manager or computer management. If I reboot the PC and try again it can sometimes see them. And I always get the sound when I plug in or remove a device.
When the PC can't see a certain USB stick, other ones work in the same port. It's so random.
It might just be the ASUS board or drivers. My strix-E gives me USB issues on and off since the day I bought it. Tried driver reinstalls and different version but it still does it. It will work fine for weeks at a time then one day it won't. Most recently it wouldn't start with my keyboard and mouse in the USB ports, no post, nothing. Unplug them and it starts fine. I just switched from that keyboard and mouse for unrelated reasons so I'm waiting to see if it happens again.
I guess that's somewhat reassuring that it could be drivers? :D

So strange that it's been rock solid for a year then this suddenly happens.
Thanks, yes I've installed the newest chipset drivers.

When I first plug in a USB stick it shows up under devices and printers, but not computer management as a drive. It will then error in device manager with a "device descriptor request failed"
Have you tried a fresh install of Windows?

Have you tried booting from a Linux live distro to see if the problem is hardware or if it is a driver?
Have you tried a fresh install of Windows?

Have you tried booting from a Linux live distro to see if the problem is hardware or if it is a driver?

I've tried a fresh install of Windows but have the same problem. Good idea on the Linux distro, I never thought of that! I'll give it a try.
Did you ever fix your problem? I am currently having the same issue.
It's likely best to start your own thread...

but... are you on hub too? Which ports exactly are having trouble?? A bit more info would be helpful. ;)

Ahh.. you did create a thread!
Last edited: