• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

System Stability Testing Software - Testing A Laptop

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.
Dec 13, 2005
Right Here Right Now
So it's been a couple years since I've had a problem like this. Just a full on, "no obvious cause" issue that I'm trying to run down before sending the unit in for RMA. Wanted to make a thread on it. Those in Gen Chat, feel free to ignore I've complained enough to y'all.

Got a MSI Prestige 14 early last week, and it's hardlocked twice under fairly light use - first time was just running HWMonitor and installing Libre Office, second time was general web browsing. It's worth noting the first time there were graphic artifacts, second time no artifacts just the hardlock.

I got it through Xotic and had them swap the OS drive, which appears comes with a fairly clean OS install.

Since getting it, I -
-Checked for and installed Windows updates
-Ran a full PCMark bench run
-Ran several hours of a 3DMark stress test & bench passes
-Currently running Memtest86+, on hour 8 and it's clean

I plan to let Memtest run overnight, then maybe set Prime95 to do its thing before heading to work.

Is there anything else that I should try?
I would try a Windows repair before looking into RMA. I have been shocked twice now as a Windows repair has fixed some minor issues I've had recently on two seperate systems.
Minor update. Had a complete brain fart earlier today.

Tossed W11 on a flash drive last night and booted into it today when I had some down time at work. No system restore point to recover from and there's no on-disk recovery partition to load from, I guess Xotic just did a clean install on their end. But boot data checked out.

Didn't realize until right now in W11, there's a way to launch the installer within the current install, and that gives the option for a repair install. Will try that next.

On the plus side I ran a full scan of the boot drive with Samsung Magician, clean.

While doing so I realized, it only locked up so far when I'm actively interacting with it. I'll try the repair install still, but has anyone run into like a HID driver that could cause freezing?
Last edited:
So update #2 - Did a repair install of W11 this morning. Install went well, as did the follow up update check.

This afternoon, spent about an hour and a half on my balcony. Tooling around with it - web browsing and Libre Office work - in the nice weather. Went well up until just a few minutes ago. Same lockup as the first, hard lock with graphic artifacts, needed a hard power cycle.

Note - There's been maybe 6 lockups so far, only 2 have had the graphic artifacts if that makes a difference.

Any ideas?
Last edited:
Except I don't have the OG memory - had Xotic do the upgrade to try and preserve the warranty.

Can it still be a RAM issue? It lasted 20+ hours under Memtest86+ without an error.
Not seeing any logging in BIOS. Windows error log is pretty inconsistent as well.

Don't have a DDR5 SODIMM kit on hand to test with, will likely go with the RMA before ordering one.
Update - WD utility came back clean on the second drive, nothing in the Windows media log about NVME namespace nor consistently in line with the lockups.

I'm a little hesitant to start tearing the the thing apart - I'm hoping to leave that up to MSI, but I have had issues with warranty work before - just in general.

The graphic artifacts happening twice now lead me to think there's a HW issue. Is there another general, broad-system stress test I can try?
I'm fully open to an RMA. I was just hoping to narrow down the problem a bit.

I had an issue with an Asus laptop back in college - it would at seemingly random send "digital static" across the onboard speakers. They couldn't figure it out :shrug:. Ended up just stripping it and pawning off a good chunk of the components.

For this I was just hoping to say, "hey, I suspect it's X" and it makes things easier for everyone.
Partial update, been dragging my feet on this.

Registered the laptop with MSI and been going back and forth with Xotic. Xotic tech actually seems fairly capable, pretty much following steps in this thread. Said it sounds like a memory issue up front but acknowledged running memtest cleared that.

Sat there reading the email thinking "wow customer support that doesn't waste time repeating steps..."


They recommended doing a few more windows repair steps that I haven't tried yet, will do that over the weekend. May even do a full reinstall - spending the afternoon reinstalling Libre Office and Firefox, oh no!

Hopefully by early next week it'll either be fixed or I'll have an RMA number.
Nowadays, it's good to at least have one spare SSD "just in case". It's easier to reinstall a fresh OS. On the other hand, I don't get how almost fresh OS can be broken. I get that sometimes too. Recently, I installed 3 the same VMs, all 3 with the same resources, and one was broken - recovery data was missing, and I couldn't run updates.
The big reason I'm considering it in this case is I had Xotic swap the boot drive, and it almost appears they did a clean install of Windows as opposed to carrying over an MSI image. If someone is working on multiple systems at once it's possible a driver install was botched. Not blaming anyone, but figured at this point it's worth a shot.

Update: Ran Xotic's recommendation yesterday - sfc /scannow for the curious. It found issues, did its thing in repairing them. Then I got a Windows Update prompt, which I followed through with. Actually used it for about an hour today - combo of web browsing and Libre Office. Not calling it a "fix" but that's probably the longest I've gotten without it locking up, which is a plus. Will continue to use it this week and see how it goes.
Last edited: