• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Toshiba 2.5" HD - Doesn't show in Win7 but does in Win10??

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

Viper69

Member
Joined
Feb 26, 2003
I have a Toshiba 2.5" external HD. Model number MQ01ABD050

It has a USB3.0 cable connection.

When I plug it into my USB port on the front of the computer (rig in sig) running Win7, it stalls my system, literally.

When I plug it into a Win10 system, mounts just fine. It has also mounted just fine on another laptop not running Win10.

Any ideas on this? I've plugged other HDDs into the front of the computer, no issue, none had a USB3.0 cable though.
 

Mighty_Miro_WD

Western Digital Representative
Joined
Jul 30, 2014
Hi there.

Sometimes this happens when there is a problem with the specific USB port you're using, so you can try to plug it in another one (preferably on the back of the PC) and see if the same behavior will occur. Also, another thing you can try is to update the USB drivers of your Win 7 system.

Cheers! :)
 

trents

Senior Member
Joined
Dec 27, 2008
Try plugging it into a USB 2.0 port on the computer you had a problem on. Could be a USB 3.0 driver issue with Windows 7 on that particular motherboard. Remember, Windlows 7 did not come with native support for USB 3.0. I had the exact same issue as you with a certain motherboard and a certain USB 3.0 external hard drive. There was nothing wrong with the drive because it worked in other computers. And another USB 3.0 external drive would work in that computer's USB 3.0 port without a problem. It was just the combination of that particular drive with that particular motherboard and it's drivers. There was some kind of compatibility issue with that combo. But when I plugged the drive into a USB 2.0 port on that computer it worked great - just a little slower of course.
 
Last edited:
OP
V

Viper69

Member
Joined
Feb 26, 2003
Toshiba 2.5" HD - Doesn't show in Win7 but does in Win10??

Thanks guys, had totally forgotten there is not native support for 3.0 with Win7.

EDIT: I plugged in the HD into a dedicated USB 3.0 port of the MOBO. The drive lights up, but the drive doesn't mount for some reason, a bit frustrating for sure.

But when plugged into a different USB3.0 port it worked. It's not critical as the drive is only 500Gigs, and I'll use it as a spare for something.
 
Last edited: