• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Touchscreen issues

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

-Ice

Member
Joined
Nov 26, 2011
I have a particular issue with my touchscreen and a program called Helios, which is basically a program designed so that flight simmers could send keyboard commands to the simulation by pressing a "button" on a touchscreen.

I've finally set up my pit and was configuring Helios and I couldn't understand why one button press was registering as two presses. For example, if I were to press 1, then press 2 on the ICP, I won't get 12, I would get 1122. At first, I thought it simply was an issue over the network (my touchscreen is on a slave PC and my sim is on a gaming PC) and the tools I was using was not calibrated, but when running Helios by itself on the slave PC, it was indeed registering two presses for each time I touched a button. After much experimentation and hair pulling, I changed the input from "pushed" (Helios detects press and release) into "closed" (Helios detects open and close) and that sorted it. Or so I thought.

The issue still persists and now, and I cannot use 3-way switches (AP, Master Arm, etc.) because one swipe or one touch counts as two so I can only go up or down, I can't get the switch to go to the middle. I've tried everything I can think of, recalibrating the touch screen, changing the mouse from right-handed to left-handed, changing the double-click speed settings, and so on. No go. It seems that Helios detects when I press on the switch, and then detects again when I let go, resulting in two "presses." Annoyingly, this only happens with Helios. I open up Notepad and use the touchscreen keyboard and one touch = one press.

I even made a totally new profile, nothing but a panel with buttons marked 1 and 2. Press button 1 and it should send "1", press button 2 and it should send "2". Open up Notepad to try it, press 1, then 2, and I get "1122"... so definitely something with how Helios works... My online searches have not turned up anything useful either.

I should mention that I've been using Helios for around 4 years now and this is the first time I've come across this problem. Perhaps it's a Windows 10 issue? The last time it worked properly was on a Win7 machine.

Any suggestions and help appreciated!
 

t1nm4n

Member
Joined
Jun 12, 2005
Location
Texas
Never used the software, but I think it might be registering the switch as a button, more like an interrupt switch. It registers the press as if you were depressing a button to turn something on and when you let up on the button it turns off, I hope that sounds right. That could be the only reason I would see for it to register two clicks, one to turn it on and again to turn it off. I have a really nice flashlight with a button on the base of it, it will only stay on as long as I hold the button and when I release it the light goes out. I am probably the worst at explaining, but I hope you got what I was saying.
 
OP
I

-Ice

Member
Joined
Nov 26, 2011
Yeah, that's exactly how it's behaving, but only with the software. Normal icons on the desktop I have to double-tap to get a double-click response.

Which is making me believe that the program is not compatible with Win10 instead of my initial thoughts of having to turn off a setting or something in Win10.