• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Transferring files between disk takes 2x space, but doesnt...

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

Mpegger

Member
Joined
Nov 28, 2001
Ok, here's a weird issue I've encountered. I'm in the process of building a dedicated backup server to backup both my main PC and my ZFS storage server to. I'm moving data around drives as I plan on taking out a couple older drives to replace them with larger drives, and on this last data swap, I'm finding that Windows is reporting 2x the drive space in use when looking at the the top level drive property (ie K:\), but when you list the directory properties, it lists the correct file size in use.

If that quick explanation was confusing:

I have approx 950GB of actual data that was moved from a 1TB drive (L:\), to a 2TB drive (K:\).

Looking at the properties of the top level of the drive (K:\), windows is reporting double that amount of space in use (approx 1.8TB).

However, if you check the properties of the folders, you find that the space in use is only the approx 950GB.

I used 3 different drive analyzers, WinDirStat, SpaceSniffer, and WizTree, and all three only find and report the 950GB of files on the drive, yet Windows still reports the drive is almost full (it's a 2TB drive).

I'm in the process of moving the data off the drive back to the older drives I was going to remove, and already, in the first batch move of around 593GB, it's moved only about 74GB of data, and it's reporting almost double that amount at the top level of the drive already. The folder properties reports the correct amount. The drive is a 1TB drive so if it's detecting 2x the mount of space in use the transfer will at some point fail, but that's still some hours away.

Anyone ever experience this or have a clue what may be going on? :confused:

[Edit]So as somewhat expected, the transfer failed with a drive full error. For some reason, it's taking double the drive space. I tried transferring a different batch of files to a different drive and was getting the same result. Now, I do have all the drives set with full drive (NTFS) compression, as this is strictly going to be a backup NAS system, so keeping everything compressed to squeeze more space out of everything was something I desired. However, seeing how I'm having this issue, I'm removing the full drive compression from one of the older empty drives and seeing if that does anything, though once again, it'll be a couple of hours before I know for sure. And I've already been at this for over a week moving files around and off drives, and this was supposed to be the last move before I finally work on the main NAS to backup everything. :/ [/edit]

[Edit2] Well now, it looks like it's a bug in Windows 10 when using full disk compression. It will correct itself upon reboot, but I can't have automated backups of my systems failing because of this. Looks like I'll be spending another week moving files around and removing disk compression. Though at this point, I might as well just nuke the drives, disable compression, and start from scratch since I plan on backing up everything anyway. :(
https://answers.microsoft.com/en-us...-is-full/aeaa3fe7-16a8-46dc-baef-883f075d5448
[/edit2]
 
Last edited: