• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

SOLVED Trouble getting Intel 750 PCIE SSD working on Asus Z170-WS Mobo

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

Mayonati

Member
Joined
Oct 31, 2008
Hi all,

I've just done a new build today, the relevant specs for this questions is that it's an Asus Z170-WS motherboard and I'm tying to get an Intel 750 NVME PCIE SSD 1.2tb (via the U.2 connector on the motherboard) working as a boot drive using Windows 10.

Here are the steps I've done so far, summarised:

After finishing the build I booted to the BIOS to check everything working ok, including turning on the U.2 port in the bios (which is disabled by default). Noticed SSD wasn't showing up. Set up all other BIOS settings, went through all options. No option for NVME settings however I hear the mobo needs updating first anyway. Bios is a September 2015 build. Finish making all changed and try rebooting a couple of times, still no SSD.

Then I inserted the Windows 10 Pro USB stick and tried to boot to that. Had some issues and after getting that sorted (turns out that CSM module must be turned on for it to boot to USB stick), went into Windows setup. Got to page where it shows drives (custom setup), no drives.

Using another PC I went and downloaded what I assume to be the drivers (hard to use Intel's site - I downloaded the "Intel Solid State Toolbox" and "SSD Data Centre Family for NVMe drivers" from This page and burned onto a disk the setup file for the Intel SSD Toolbox plus the Driver32 and Driver64 folders from the other one.

I then booted the Windows setup again and at the Disks pages I chose to select a driver and went onto the CD - the setup file didn't show up so I highlighted the X64 folder. After doing a scan, nothing showed up. I ticked the "Show drivers for hardware that isn't present" (or whatever that tick box was called) and it showed that the Intel 750 driver was there, greyed out. Selecting it and trying to install that driver just dropped me back to the disks page with no disks showing. It couldn't see the disk at all.

After some more fiddling around in the bios, I installed a regular 150GB SATA hard drive and installed Windows 7 on that, booting to it fine. I then used the Mobo driver CD and installed all the mobo drivers and utilities. I downloaded a copy of the latest bios version (0602, 03/07/16) and went back into the BIOS and flashed it successfully. I then re-set-up everything in the BIOS and hunted through every option again - still, nothing mentioning NVME. I tried booting with the SATA drive unplugged with both CSM enabled and disabled, trying a couple of other options etc and neither the quick bios nor Windows 10 setup could see the drive.

I went back into the SATA drive's Win7 install and installed the Intel Solid State Drive Toolbox from Intel's site and ran it - it cannot see the drive at all.

At this point I unplugged everything and removed the U.2 drive, then plugged it in again and double-checked the connectors. Booted to BIOS - nothing. Booted to Win7 and checked Intel's SSD Toolbox app once more - nothing. Also checked Windows' Computer Management snap-in just in case it was showing in there - nope.

Is there something I'm missing or is there a chance I just have a faulty drive or motherboard? Or maybe the mobo doesn't support U.2 Intel 750 drives? (despite having the port for them). Alternatively, maybe I downloaded the wrong drivers or there's something else I need to enable?

Any tips would be greatly appreciated, thank you!

Edit: Just spent some time changing variations of turning CSM on or off, enabling or disabling XMP mode in the Ai Overclock Tuner (as recommended on another post I saw somewhere), and enabling or disabling the M.2 Hyper Kit mode, none of these options seem to make any difference. P.s. The cable that I'm using to connect the SSD is the one that came in the box, and is plugged into the only port on the SSD but that end of the cable also splits off into another kind of plug, seems like SATA power or something like that. Am I being dense and need to plug this into something or is it redundant? Just checking I'm not doing something stupid.

Edit2: Also tried a couple of other things including tweaking the settings in CSM such as forcing UEFI mode only or prioritising UEFI on the various devices (such as PCIE). Turns out that the Windows 10 drive will refuse to load with anything other than the "UEFI and Legacy Oprom" and the SSD can't be seen in the BIOS regardless. I also tested the Win10 installer with the 150GB SATA drive installed as well as the SSD - still nothing.

Also after reading a website where someone said that they could boot with only one PCIE device installed but not two (i.e. no graphics card), I also tried removing my graphics card and booting using the mobo's onboard graphics and only the SSD installed in U.2 (tested in the Bios' quick settings check, using the Windows 10 installer, and in Win7 using the Intel SSD Toolbox - nothing, nothing, and nothing again).

Possible causes imagined so far (haven't discounted anything yet):

* Faulty SSD
* Faulty cable connecting to mobo
* Faulty Mobo
* BIOS settings incorrectly configured
* Incorrect driver downloaded / install method used
* Newer/different Mobo BIOS flash needed
* Third party app or config needed
* This SSD not compatible with this Mobo
 
Last edited:

ATMINSIDE

Sim Racing Aficionado Co-Owner
Joined
Jun 28, 2012
Yes you need both connections to the SSD. As is there us no power going to it.
 
OP
M

Mayonati

Member
Joined
Oct 31, 2008
Yes you need both connections to the SSD. As is there us no power going to it.

Thanks, there don't seem to be any other ports on the SSD though, unless I'm missing something? I'll try and get a photo and upload soon

Edit: Ok, I'm a frickin' idiot, just realised that that second loose cable is an input for a SATA power. Just plugged it in - BIOS still doesn't see it and nor does the software in Windows, but at least now I have a chance to do some more troubleshooting. Will report back soon whether I got it working or not, hopefully it's just a case of updating some BIOS settings or something now. Thanks for the tip - fingers crossed!
 
Last edited:
OP
M

Mayonati

Member
Joined
Oct 31, 2008
Update - ok, getting closer but still not there yet. Plugged in SATA power (FML) and booted into Win7 partition. Installed drivers package and disk showed up in Windows, so far so good:

photo_2016-07-20_12-45-43.jpg

Installed the latest firmware and rebooted a couple of times. The Intel SSD app in Windows can see it but the BIOS can't, at all. Tried removing the Win7 hard drive and running Windows 10 USB stick setup. Whilst it CAN now 'see' the drive (and loading the driver shows the drive as "there"), it says that I cannot install Windows to this drive. I get the error:

Windows cannot be installed to this disk. This computer's hardware may not support booting to this disk. Ensure that the disk's controller is enabled in the computer's BIOS menu.

Rebooting again, I can see that there *is* an entry in the BIOS about this device (under Advanced, I think):

photo_2016-07-20_12-45-47.jpg

However in the basic setup the drive does not show up, nor is it available to set up under the boot menu or in any other part of the BIOS.

Is there something I need to configure in the BIOS to enable the controller? I haven't see anything about NVMe at all, and U.2 port is turned off (the M.2 Hyper Kit functionality is turned off, I'm not sure if that's important. CSM is fully enabled otherwise it just boots to the BIOS every time, refusing to see the Windows 10 flash drive).

Tl;Dr: What do I need to set up in the BIOS to make it recognise this as a bootable drive?

Edit: I also tried the tips in This video (even thought it's for M.2 I thought it might help - not much info out there for U.2 owners!)
Unfortunately this didn't work either - setting CSM to anything other than Enabled and the mode to UEFI plus Legacy just causes the BIOS to not recognise any boot devices (even the Windows installer USB) and only boot to the bios, and changing the OS type from Windows to Other didn't help. I couldn't clear the secure boot keys either since I didn't have that option in my bios.

I've taken some relevant photos and screenshots.

Photo of the Windows 10 installer error:
IMG_8759.JPG

Some various BIOS settings as they currently are - can anyone see anything wrong?

160720135813 copy.jpg
160720135801 copy.jpg
160720135857 copy.jpg
160720135744 copy.jpg
160720135822 copy.jpg
160720135729 copy.jpg


Edit: I also just tried clicking "Install default secure boot keys" under Key Management - it didn't do anything and there are no options to delete the keys. When exiting and saving it didn't tell me anything changed. I tried booting to the Win10 installer with both "Other OS" and "Windows UEFI Mode" enabled and it still doesn't work. Also still no option to delete the boot keys ("Clear Secure Boot keys" at This point in the video - that option isn't there at all for me and clicking Install defaults doesn't do anything).

Edit: I also read somewhere that you shouldn't have any SATA devices plugged in when setting up the UEFI drive so I just tested unplugging the DVD drive as well and testing Win10 installer in three modes - CSM disabled (boots to BIOS only), and OS type to Other and UEFI Windows, none of which worked.
 
Last edited:

ATMINSIDE

Sim Racing Aficionado Co-Owner
Joined
Jun 28, 2012
What options do you have in Advanced -> SATA Mode Selection?
 
OP
M

Mayonati

Member
Joined
Oct 31, 2008
Yep, I tried all variations of leaving it raw, setting up a partition but not formatting, and formatting. As a test I just checked the following:

Booted to Win 10 installer USB
Currently no partition
Error displayed is "Windows can't be installed to this drive" (This is a link which goes to the message I pasted earlier)
Click "New" and apply
Error displayed is "Windows can't be installed on Drive 0 partition 1"
Click format
Error displayed is "Windows can't be installed on Drive 0 partition 1"
Reboot PC and launch back into installer
Error displayed is "Windows can't be installed on Drive 0 partition 1"
 
OP
M

Mayonati

Member
Joined
Oct 31, 2008
Yeah, I just tested delete + new though - "Windows can't be installed to this drive" when there's no partition, "Windows can't be installed on Drive 0 partition 1" when there is, and the same "Windows cannot be installed to this disk. This computer's hardware may not support booting to this disk. Ensure that the disk's controller is enabled in the computer's BIOS menu. " when you click through
 

JrClocker

AKA: JrMiyagi
Joined
Sep 25, 2015
I think the problem is with the language selection...you selected English!

Just kidding! :D

You have tried everything that I can think of.

The only other item I could add is try setting the boot device mode to UEFI only.
 
OP
M

Mayonati

Member
Joined
Oct 31, 2008
Hah! Feels like the only thing I haven't tried to be honest.

Yeah, I tried UEFI only - when I set it to that, or to disabled, the BIOS won't recognise any drives and will only boot into the BIOS. Only when set to UEFI and Legacy will it boot to a drive.
I've also just tested flashing the mobo BIOS again just in case it went wrong the first time - no difference.
I then tried disabling the SATA controller completely - no difference in BIOS or Win 10 setup :(
 
OP
M

Mayonati

Member
Joined
Oct 31, 2008
Yeah, I had that thought before but it doesn't work unfortunately.

To test, I just booted it again to the Win 10 installer and first tried to click "Next" past this point both with the hard drive raw, then partition created, then formatted. Then I loaded the driver that I already have and tried again - here are the results:

IMG_8761.JPG
IMG_8760.JPG

With regards to which driver to use - which one should I use and where should I get it from? The one I'm currently using is the "Driver64" folder of This Intel file. The toolkit exe is on the disk but it's not what I'm trying to load the driver from. Windows setup recognises the validity of the driver in the Driver64 folder (giving me errors if I try to use the base D:\ directory of Driver32) but I can't get past that error ("We couldn't create a new partition or locate an existing one. For more information, see the Setup log files."

I can't find any other Intel drivers but if someone could link me to, or upload a copy of their ones that are working or one that you know definitely works that would be great, assuming that my drivers are unlikely to be working?
 
OP
M

Mayonati

Member
Joined
Oct 31, 2008
Ok - I just got it working! Crazy fix - I used the exact CSM config from habbajabba's linked PDF (as below):

IMG_8762.JPG

Not expecting it to work, but when I went into the Windows 10 loader the message about not being able to install was no longer there, and clicking next:

IMG_8764.JPG

Finally I checked the BIOS and the SSD is now showing up as a boot drive and in the easy mode, even without installing Windows yet. I then finished off the Win 10 install just as a quick test and it works fine!

Thanks everyone for the tips and suggestions, and I hope this thread helps anyone else who runs into these problems :).
 

ATMINSIDE

Sim Racing Aficionado Co-Owner
Joined
Jun 28, 2012
When you boot to the install media, are you booting in UEFI mode?

Edit: Just saw your post, I was researching while on the page, glad you got it!!!!!
 
OP
M

Mayonati

Member
Joined
Oct 31, 2008
When you boot to the install media, are you booting in UEFI mode?

Edit: Just saw your post, I was researching while on the page, glad you got it!!!!!

Thanks! It was pretty much a random pot-shot to be honest, I was at the point of giving up and about to order a regular SSD instead but after reading that PDF I thought I might as well give that combo a shot. Good job I did! Thanks again for all your help with my new build questions, I really appreciate it :).