• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Tryied installing Linux...

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

Krieger

Member
Joined
Jan 31, 2002
Location
North of Boston, MA
Hey guys,

I installed 2 different distros of linux(one that I know worked previously with my hardware) One is Redhat 7.1 and the other is Mandrake 9. The same problem occurs which is:

They both install fine, but after rebooting after the install they start X-windows. But the window never finishes loading. It just hangs with the cursor at the middle of the screen... has anyone ever seen this before?

Thanks. i'd be happy to supply any info you need. I'm not at my system right now so I can't give you a complete list of specs. I'll do that when I get home.
 

Titan386

Senior Member
Joined
Jun 8, 2002
Well there seems to be a problem with your X server (duh). The best thing to do is to change into the text-only runlevel. This is runlevel 3 on redhat, anyone know if its the same in mandrake? You can edit the runlevel in the /etc/inittab file, in the line that looks like:
id:5:initdefault
Considering you can't log in, try booting from your install disk, they usually can drop you to a recover prompt from which you can mount your root filesystem, change the file, and reboot.

Once you've done that, you will be at a command prompt instead of a GUI when the system boots. Try starting X with startx and seeing if it gives you any errors. Tell us what you get and we'll try to help you.

Good luck.
 

tbirdkiri

Member
Joined
Jul 24, 2001
Location
nor-cal
Heh, mandrake can be a pain... its supposed to be easy for anyone to use, but if you go into it trying to repair it to the way it should be you find that mandrake has things all misplaced or replaced....

anyway.... i know that if you were capable of booting into X you could turn off the feature that makes it autoload Xserver. i turn it off cause i cant stand the graphical login. from a repair console i would do what titan said.
 

KraziKid

Member
Joined
Nov 22, 2002
I had the same problem when I installed RedHat. What I figured out was that if you set the color depth too high, X won't start for some reason without the NVIDIA GLX drivers. What I would recommend is changing the color depth setting, and try starting X manually. If that doesn't fix it, try playing with the resolution settings. That seemed to fix it for me, hope this helps. I personally use CLI now, instead of X though. The computer I'm running Linux on is my Router, and there is no need for GUI. Also, if you ever plan on using SSH, you will have to learn the bash prompt and commands. Also, I've moved away from the "n00b" distro's because for some reason, RedHat, Mandrake, and I don't get along very well. So I now use slackware. :D
 
OP
K

Krieger

Member
Joined
Jan 31, 2002
Location
North of Boston, MA
Krazikid thanks I'll try that too. I'm looking to learn Linux(again) and get a better understanding, then move to a more complex distro.