• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Trying to get some sound through TeamViewer

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

knoober

Member
Joined
Mar 18, 2015
About the only criticism I can find for TeamViewer is the fact that it will not pass audio from Linux to Windows. A recent change in my setup has left me wanting sound for my NAS/etc box and I thought I had found the answer -> http://wp.xin.at/archives/3862

It sounds like it will work. It make sense. But when I get to the part about pulling up teamviwers winecfg file I throw this error
Code:
Init...
CheckCPU: SSE2 support: yes
Checking setup...
flock: 300: Bad file descriptor
wine client error:0: version mismatch 440/447.
Your wineserver binary was not upgraded correctly,
or you have an older one somewhere in your PATH.
Or maybe the wrong wineserver is still running?

For me this breaks Teamviewer after a restart but can be fixed with uninstall/reinstall so not that big of a deal. But I did run into some part where I had to extrapolate on the intructions and that must be where the error stems from.

Here are the steps I had to re-arrange a bit:
when the author is explaining about what files to backup and which to copy
Code:
cp /usr/lib/libwine.so.1.0 /opt/teamviewer/tv_bin/wine/lib

/usr/lib/libwine.so.1.0 is not a valid path on my setup. my copy of libwine.so.1.0 comes from "/opt/wine-devel/lib/

There is a "wine" directory that is to be copied from wine to teamviewer's wine that is also in a path related to wine-devel.

I had originally thought that the error having to do with version mismatch was because I was taking the binaries from wine-devel instead of a wine-stable (which I cannot find on my system anywhere even though that is my original choice for instiallation). So I started over. I removed wine-stable and teamviewer to start with a clean environment. I rebuilt all the steps but this time used wine-devel and I am still getting the same error message.

Well there's my story guys. Does anyone have a clue what is going on with that error? A way to RDP between linux and Windows (with sound)? Ive googled a bit for replacement RDP clients and it seems there are a few that may pass sound through, but my preferred solution is to get this fix working. Thanks in advance
 

Stratus_ss

Overclockix Snake Charming Senior, Alt OS Content
Joined
Jan 24, 2006
Location
Ontario Canada
That error usually means there is some remnence of wine kicking around. Have you tried killing them?

Code:
pkill wine
pkill exe

You also look at

Code:
pstree

To make sure there are no other bits relating to wine hanging around
 
OP
knoober

knoober

Member
Joined
Mar 18, 2015
I tried killing the wineserver with
Code:
 wineserver - k
With no effect. I have been trying trying to figure out what version comes packed with TeamViewer so I can match it, but so far I haven't come up with anything. I completely removed wine (except for the parts in TV) and still got the error also. I'll look into pstree (I'm guessing process tree?) and see what I can find there also.

On a side note I've also nearly destroyed my install by trying different RDP/vnc clients. The last one took the GUI with it and I couldn't get anything to work without removing the /. Xauthority and letting it rebuild. Even after that I still had take it out to the garage (where the monitor is) and reinstall TeamViewer.

I'll report back if I find anything good and be sure to let me know if you randomly think of anything else. Thanks
 

Stratus_ss

Overclockix Snake Charming Senior, Alt OS Content
Joined
Jan 24, 2006
Location
Ontario Canada
I have only ever used it on linux (though it does have a windows client) you can try freenx. There was one other one i used several years ago that was quite good for sound (I used it on a raspberry pi) but I don't recall the name, if I think of it i will post back
 
OP
knoober

knoober

Member
Joined
Mar 18, 2015
https://ubuntuforums.org/showthread.php?t=2336587

Freenx appears to not have a xenial candidate. I tried x2go (I think it is mentioned in this link, but it might be another) and I ran into issues with a black screen. I went through x2go, remmina and xrdp without having a successful session. Tightvnc was fine when it worked, but x2go left X in a sorry state of some sort and I could no longer connect with Tightvnc either (which has no sound BTW). Reading I have done suggests No Machine as the successor to freenx and so far so good. I've got sound pass through and everything else seems to be working also. I'll have to keep TeamViewer for access via Android (I think... Quick search in the Playstore didn't show anything but I did see an Arm version on the No Machine website)
 

Stratus_ss

Overclockix Snake Charming Senior, Alt OS Content
Joined
Jan 24, 2006
Location
Ontario Canada
well i am glad that you have something that covers your basics!

My knowledge of all things Ubuntu is fading fast. I moved over to Antergos about 3 years ago and havent looked back.

I work for Red Hat, so I roll CentOS (I love 7 btw, what a great release) on the server. I have been slowly replacing all my Ubuntu boxes, though not because of my employer. I have had a number of installs that eventually crop up with problems on boot up (that Report a Problem diaglogue seems to be ever present...)

At any rate its always good to see what others are doing so I am not completely divorsed from it
 

habbajabba

Member
Joined
Oct 29, 2005
Location
Oregon
Have you tried Anydesk? It does have linux debs. https://anydesk.com/platforms. I've used it in windows on my lan with great results but did not try audio nor have I tried remoting in with it yet. It's at 3.0 for windows and at 2.6.1-1 for buntu.
 
OP
knoober

knoober

Member
Joined
Mar 18, 2015
No Ive actually never even run across any mention of it. For now NoMachine is doing the work, but there is no guarantee that an update won't break that. I'll post back with some results when I get around to testing further