• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Unable to SLI 2x GTX-970's in Windows 10

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

MaddMutt

Member
Joined
Jan 12, 2015
I'm currently test my collection of video cards and have hit a snag in Windows 10 :-( I was able to run 2x GTX-960's (4GB) in SLI and 2x GTX-980Ti's in SLI but not the GTX-970's. I have a EVGA GTX-970 FTW and 2 EVGA GTX-970 SSC that are both 4GB versions. I'll admit that I have not tried the 2 SSC's in SLI yet BUT it should have still worked. NVidia control panel - stated that I needed to install the SLI Bridge for them to properly SLI?? I used several different SLI bridges but none worked with this setup, they worked with the GTX-6xx, 7xx, and 9xx cards.
Can a NVidia card properly work but the SLI Fingers be damaged?? I have checked them and also cleaned them and see no damage.

Thank You :)
 

dejo

Senior Moment Senior Member
Joined
Nov 11, 2001
there is actually a work around that works, I cant find what I used when I had my 970's. There really was not that much to gain from my efforts
 

JLK03F150

What have I done! Member
Joined
May 17, 2005
Location
Georgia
there is actually a work around that works, I cant find what I used when I had my 970's. There really was not that much to gain from my efforts

I know "SLI with any card" over at TPU doesn't work.