• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

usb 3.0 "this device can perform faster" can't solve

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

Pepi93

Member
Joined
Jul 12, 2002
Ever since I got my new monitor I've been having this issue...

BenQ BL3200PT

Particularly with the SD card, usb 3.0 hub which is connected via a usb 3.0 cable to my PC.

1) I've tried reinstalling usb 3.0 intel drivers.
2) Tried plugging the monitor hub into different usb ports

I also don't have anything else plugged into my usb ports except for my webcam. My keyboard/mouse, xbox controller have their own usb 2.0 ports that they are plugged into

If I unplug the monitor hub cable and plug it into a different port, it will work for a day or so, meaning ChipGenius will will show me that it's connected to a usb 3.0 hub and then later the same error will get triggered.

Any suggestions?

Thanks

Untitled.jpg
 

EarthDog

Gulper Nozzle Co-Owner
Joined
Dec 15, 2008
Location
Buckeyes!
WTH is chipgenius? Are you sure it is correct?

Typically windows will tell you that... has windows done so? Have you tried to confirm its accuracy with a large file transfer and see what speeds you get?
 

ATMINSIDE

Sim Racing Aficionado Co-Owner
Joined
Jun 28, 2012
Unless you're using this hub to transfer files to a USB 3.0 flash drive which can actually perform at a level past USB 2.0, I wouldn't worry about it.
 
OP
Pepi93

Pepi93

Member
Joined
Jul 12, 2002
I'm simply worried or rather annoyed about the windows "this device can perform faster" error. The chip genius I used to simply narrow down to see which peripheral was giving me the signal.

I've tried disabling the notification where windows tells me if a device can perform faster etc...nothing works.

It's also the monitor USB/SD card reader hub that triggers it and nothing else.

I guess I could just ignore it but what happens is it works ok for a day or so, and then the error will just pop up from windows. :(
 
OP
Pepi93

Pepi93

Member
Joined
Jul 12, 2002
I only tried it with one of my SD cards to make sure it works when the new monitor came. No I did not try a different USB cable, figured since this was new it was fine.
I don't have a different cable to try for now either :(
 
Last edited: