• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Using on-board graphics with a discrete GPU?

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

-Ice

Member
Joined
Nov 26, 2011
I have an i5 6600K on a Gigatbyte GA-Z170X Gaming 7 motherboard with a GTX 980Ti card installed. I have 4 screens hooked up to the 980Ti and I want to connect my 5th screen to the computer using the motherboard's HDMI port. I've enabled the Internal Graphics option on the BIOS but the 5th screen is still blank when the PC turns on. Google searches have come up with vague answers. Can anyone help? Is this possible?

Thanks in advance for any help!
 

jaymz9350

Member
Joined
May 13, 2006
Did you install the Intel graphics driver? I run both discrete graphics (SLI 970's) and the iGPU on my 4790k
 
OP
I

-Ice

Member
Joined
Nov 26, 2011
I would think so. I use the Gigabyte App Center to update the drivers.

I tried plugging one of my main screens (Display Port cable) on the DP output of the motherboard and it works! I initially connected the touchscreen via HDMI and it didn't work. So for some reason, the DP output works but not the HDMI. Weird. I guess I'll buy another Display Port cable or an adapter.
 

jaymz9350

Member
Joined
May 13, 2006
Have you tried removing and reinstalling the Intel driver. If it was disabled in the bios it may not be installed or correctly installed. I had this issue when I set mine up
 
OP
I

-Ice

Member
Joined
Nov 26, 2011
I uninstalled the driver, it asked me to reboot the computer. I did, then the PC just "recognized" something and set up the device for it and I noticed the driver is re-installed automatically without me having to do anything. I plugged in the monitor again and VIOLA!! Working!

Thanks guys! I guess this is the driver equivalent of "turn it off and turn it on again!!" :D