• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

very slow transfer between 2 computer

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

rob3rtz

Member
Joined
Feb 2, 2002
now i have 2 computer networked
my main comp is xp1900 with win xp pro and the second one is athlon 700 on win me

i connect them using router (netgear rt 314).. i able to see other's drive on the other computer..but when i try to transfer between them..
it takes forever just to transfer 15 MB..

also my second computer speed for d/l is very slow (10KB/s) compared to the main comp(up to 300KB/s)..is this because of the second computer is slow?..

or something goes wrong?(cable, etc )

daes anybody encounter the same problem when transfering file ??
 
OP
R

rob3rtz

Member
Joined
Feb 2, 2002
oh yeah....
i just tried to transfer the other way( from second to my main comp)..
it was fine..i try transfer 30MB..it just take 20-30 second..

so the probelom is when transfer from the main comp to the second one...
 

WildArmSX

Member
Joined
Sep 11, 2002
Location
Toronto Canada
The router does not give you all the avaiable bandwidth to you becasue of its forward process you only get 70% of the avaiable bandwidth. Pls tell us what kinda system you have, what kinda nic in each computer? if your nic int he old one is 10 thats why
 

su root

Senior Member, --, I teach people how to read your
Joined
Aug 25, 2001
Location
Ontario, Canada
I've seen this problem before... some OS's don't like to "push" data across the network, and some don't like to "pull" across the network.. as far as I can tell, theres no rhyme or reason to it, one install of 2k will work fine both ways, another will favour things being pulled across the network, and give crappy speed if you go to the other computer and "push" to it.
 
OP
R

rob3rtz

Member
Joined
Feb 2, 2002
thx for reply..
for both i use NIC from Dlink i believe..it support 10/100
main comp : xp1900 on xp333 512 ram pc2700(xp pro)
second comp : ahlon 700 on MB(don't remember) with 420 Mb ram(win ME)

now i try..winxp pro and mandrake9 to check if the OS is the problem as su root said...

any suggestion will be great..

thx
 
OP
R

rob3rtz

Member
Joined
Feb 2, 2002
hmm.. i just change the win me with mandrake 9.0 (linux)..
after all the setting.. i could see the win xp share drive on my linux ..
but when transfering files from them..
it got the same problem...may be worst, this time i couldn't transfer even *.mp3 file

i couldn't try the other way because my windows can't see my linux yet..

i did ping from both way..and it works fine, and it the speed looks normal

does anyone know the problem is?
(not OS i think..but who knows)
 

JasonKosi

Member
hmmm, are any of your cables running near power cables for more than a few feet, kinked, coiled up or over 300ft (100 meters) in length?


At this point, here are the tests I would conduct...

1) Try swapping the ethernet cables betweent he two computers.
If Computer A is having a problem and computer B isn't before the swap, but the reverse is true after, then I'd say you need to inspect your cables and possible reroute or replace them. If nothing changes, try this next step.

2) Swap network cards. Look for the same changes in behavior that you looked for in test 1. If still no change, go on to 3.

3) Swap which ports the computers are connected to on the router. Again, look for the same changes as you did in 1 and 2. If none of these produce any results, then I'm out of ideas.
 
OP
R

rob3rtz

Member
Joined
Feb 2, 2002
hmm i can't do number 1, cause the cable length is difference

but do number 3, and still got the same problem

will do number tomorrow..i have homework and test ..

by the way my cable is near power cable..but after u told me..i moved it and still no luck

by the way now it's getting worse, the linux box able to see the drive on windows box but it can't see what inside it..so like a blank drive
 

JDXNC

Member
Joined
Jan 16, 2002
I have the same problem on my network and have tried everything to no avail and all my rigs run XP or 2k... any help would be greatly appreciated, and as once suggested before. it is not ICS, I disabled it and still have the same problem.
 

Jon

Just Another Retired Moderator
Joined
Dec 19, 2000
Location
Lawrenceville, GA
I don't know if it's the same in XP as it is with Win2K, but when SP3 for Win2K came out it caused a horrible problem with transfers between two different PCs with different MTU settings. A patch for a Win2K machine not running SP3 was needed to transfer files to another where it was installed.

I don't know if this affects XP and whether or not there is anything available for other versions but it may be worth a look into.

I only mention this because I recently had this problem and had terribly slow transfer rates and eventually they would fail and disconnect with an error.
 

su root

Senior Member, --, I teach people how to read your
Joined
Aug 25, 2001
Location
Ontario, Canada
well, if you get a chance, you can try swapping out the NICs, and trying other NICs. I highly doubt that one of them is dead, they both are good NICs.

If you have another machine around, you can try plugging it in, and transfer to and from it.. you may be able to narrow down which computer it is that is slowing everything down.

Also, disable "QoS packet Scheduler" in your network settings.. that is known to flood the network & slow everything down. Disable/uninstall any other protocols except TCP/IP.


EDIT:
OK I did a bit of research. On most NIC drivers, it allows you to change the duplex settings of your card. Try setting both cards to 100Mbits/Full Duplex. To do this, go into the properties of your NIC in device manager, and one of the advanced options should let you change the Duplexity.

Also, are you using "soft" patch cables, or "hard" vertical cables? apparently the soft ones don't like to run at 100Mbits for more than like 8 feet or so.. (that's heresay)
 
Last edited:

JasonKosi

Member
rob3rtz said:
hmm i can't do number 1, cause the cable length is difference

Can you at least try the longer cable attached to the closer computer? Which computer is having the probem (the closer or farther one)?


but do number 3, and still got the same problem

How do you mean the same problem? Swapping the cards means that the problem does or does not switch computers with the card?


by the way my cable is near power cable..but after u told me..i moved it and still no luck

Well, that one was a long shot. Are either of the cables coiled up tightly (like how they are packaged if purchased from the store)?
 
OP
R

rob3rtz

Member
Joined
Feb 2, 2002
ok.. i did swapped the NIC on both comp..(also try to use other PCI slot)

tried switching the router port for both comp..

tried switching the cable...

still got the same prob. the comp 2 can browse file on comp 1 but not able to copy a file..

tried to dissable "QoS packet Scheduler" and set 100 full duplex but still nothing happend..

comp1 right now is not able to access comp 2 because it is linux based and i am newbie on networking these 2 system..

but when i still using Win Xp - Win Me..
comp 1 can browse and copy file from comp 2
but comp 2 ONLY able to browse and not copying

by the way.. i assume, i use "soft" patch cable (not sure, but it's the common cable as peoples usually use)
cable length : (1.) 4 ft and (2.) around 10 ft
 

CoolLion

Member
Joined
Jun 3, 2002
The very first thing you net to get is an uncrossed cat 5 cable and connect card to card with nothing in between. If you got good speed your cables are screwed or the router needs to go rma

If you still have the problem with the peer to peer connection, i will go into more tracing with ya
 
OP
R

rob3rtz

Member
Joined
Feb 2, 2002
ok try to connect 2 comp directly..
and still.. comp 1 able to transfer file from comp 2 with normal speed(i just figure out how windows read linux system... hehehe)

but again, comp2 not able to transfer file from comp1

one thing that bother me..on my linux box (comp2) the driver for network card is DLink 538, but i using Dlink 530

is this matter?..will try to update the driver after i found how to..or anybody know how to update driver in mandrake 9.0

also i notice that my windows box(comp1) able to browse the linux as normal speed but sometimes the linux need a few second to browse the windows drive..(e.g it takes 20 second to browse c:\ and takes 20 more to brose c:\mymusic\...etc..but sometimes they work fine)
 
OP
R

rob3rtz

Member
Joined
Feb 2, 2002
i think it is TCP/IP as regular..for win xp pro..

not sure for the linux..( i think they are the same, isn't it?)
 

su root

Senior Member, --, I teach people how to read your
Joined
Aug 25, 2001
Location
Ontario, Canada
UnseenMenace said:
What protocols are the systems using to communicate with each other ?

It is generally accepted that all machines nowadays use TCP/IP to communicate with eachother. However, back in the old days, there were other protocols, like IPX/SPX, which was used with Novell, but now Novell has moved to TCP/IP with it's newest version. Some games still use IPX as a connection method though. NetBEUI is a non-routeable protocol, so it can't support more than one network of computers. It is very fast and has little overhead, and some people still use it.

Generally, you want all of your machines to use TCP/IP exclusively. If you game, and use great games like Starcraft, Warcraft, and others over the network, then you'll want IPX/SPX installed aswell. If you are having problems getting TCP/IP to work, then you can always try NetBEUI, which will work with no configuration, and let you do the simplest communication with another local computer as a fallback to TCP/IP.