• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Vista very dependant on disk speed?

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

KonaKona

Trashcan Man Member
Joined
Nov 25, 2008
Right so I'm working on getting a vista install going for some benchmarking. I had server 2008 on here but god it was bad. Vista is having some of the same problems, but since the version I installed has almost nothing on it, it's a bit better.

From what it seems, any time that anything is using the disk at all, there is some bad lag problems. It's like your running on 128mb of ram or something. It's probably being caused by this ancient IDE hard drive I'm using (Darn shame my 5.25in drive didn't want to detect, or I'd be on it right now). Is there anything I can do to get vista to stop being so dependant of the disk and get it to run smoother, or is it just going to be really sucky like this unless I move to a new hard drive?

EDIT: Turned off all of the virtual ram in drive whatever that junk is, still having some problems.
 
Last edited:

TollhouseFrank

Senior Headphone Guru
Joined
Nov 29, 2004
Location
T3h [email protected]!
so you turned off prefetch/superfetch (whichever one it is that thrashes the HD constantly to keep the ram full)

short of that, there isn't much you can do short of upgrading to a faster drive.
 

Know Nuttin

Senior Member
Joined
Mar 25, 2004
Location
Ontario, Canada
Maybe your drive is still being indexed also?
IDE drive, it is probably pretty slow in comparison to a new drive, even a 500GB $50 drive may be markedly faster.
 

RJARRRPCGP

Member
Joined
May 30, 2004
so you turned off prefetch/superfetch (whichever one it is that thrashes the HD constantly to keep the ram full)

No, not Prefetch! Disabling that will cause apps to launch slower!

You should disable Windows Defender and indexing instead.
 
Last edited:

johnz

Member
Joined
May 30, 2004
No, it's not Prefetch! Disabling that will cause apps to launch slower!

You should disable Windows Defender and indexing instead.

That depends. Defender I can go with, indexing is user specific. People who search a lot would be better off leaving it on. It also helps launching applications by typing into the search box. Indexing doesn't really take much in the way of resources. After the computer's setup, indexing is a very light hit unless you constantly move things around, and add/remove programs. The resource hit is >0, but not by much. I wouldn't give generic advice to disable indexing, but it may be beneficial to some users.
 

johnz

Member
Joined
May 30, 2004
How much slower? 2-3 seconds? Is that really such a bad thing?

I'd rather let it take 2-3 more seconds to find/load the program vs. having my HD constantly thrashed.

It doesn't constantly thrash the hd though. I have very light activity on my hd, and I have 8gb of ram to fill.
 

TollhouseFrank

Senior Headphone Guru
Joined
Nov 29, 2004
Location
T3h [email protected]!
It doesn't constantly thrash the hd though. I have very light activity on my hd, and I have 8gb of ram to fill.

any access beyond loading a program or hitting the swap when switching between 2 memory hungry programs is thrashing.


Though it must be nice to have 8gb of RAM. Still stuck with 2 on both my desktop and laptop... but that's ok. I still rarely go over 768mb Used on both unless i'm gaming on the desktop... and even then... it rarely goes over 1gb used.

I'm still paranoid about memory usage even all these years after 95 and 98 made me paranoid (after switching from MacOS8 to win 95... lemme tell ya... memory became a big concern all of the sudden... and old habits die hard...)
 

Niku-Sama

Member
Joined
Jan 13, 2005
superfetch is differnt, it still doesent do much good. intexing can thrash a drive too and i dont know how long it takes me to find something, if i search my computer for it, with the indexing off. it doesent take long, it never had, indexing just takes up that much in resources.

is the OP also saying he turned pagefile off?


my guess is that write caching and advanced performance arent enabled if they are an option in the disk properties in device manager, its an old standard IDE and not ATA66/100/133 drive and its 5400 RPM

the ATA 66/100/133 could be another thing to check for if it is one of those drive but its not running in one of those modes