• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Weird PSU problem, wont boot

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.


Dec 28, 2001
Toronto, Canada
I am build a comp for a family member and bought an asus case witha powersupply. They don't need anything fancy. Im running it with an Epox 8K7A+, an atx 1.0 board.

I set it all up with minimal components and the fans turn for like a split second and it stops. I thought the PSU was dead because I hooked it up to a working Enermax and it posted immeditely without any problems

So I brought it back to the store I bought it from, they hooked it up to their test board, an atx 2.0 board and it booted fine for them.

Any ideas what might be causing this?
Something could be shorting out the psu in the case, or it can be grounding itself out somewhere when you mount it.

Try hooking up the psu to the mobo and stuff, but don't mount it in the case and see if it powers up. if it does, then you'll have to use rubber/cardboard washers to mount the psu back into the case. Maybe this will work. It's worked for me several times.
I just decied to take the easy route and give my other computer this new psu.

SO much christmas shopping to do still can't waste too much time troubleshooting.

Such a weird problem, i had both psu's and the board setup out of the case to make certain there was no shorts. The old one worked, new one wouldnt.

New one seems to be running fine in the other one.