• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Win2k and Mac OS X

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

fade2black

Member
Joined
Mar 7, 2002
Location
NE Ohio
I added a G4 to my home network about a month ago. I've been trying to get Dave running on it (a file sharing program) but I can't ping my 2k box from the mac. I can ping the router and the mac from my 2k box, but from the mac I can only ping the router. Both boxes access the Internet fine. Any ideas on why my 2k box isn't replying to the ICMP requests? Do I have to have the AppleTalk protocol running?

PS - THIS is why I hate macs!! :mad:

- Fade
 

rugby

King of Cats Senior
Joined
Feb 2, 2001
Location
Chicago, IL
The best cross platform sharing tool I've seen is PCMacLan. it's by Miramarsys and installs on Win2k. Basically it's Appletalk for Windows. MUCH better than the Appletalk that's installed with win2k optionally. You then turn on filesharing on the Mac and it will show up in the network neighborhood for your PC.

Why is it the Mac's fault that the win2k box isn't responding to icmp requests? That has nothing to do with Appletalk, it's a different layer protocol from Appletalk and will not affect it.

If you have any more questions email me at [email protected] or PM me as I'm not around here as much as of late due to work. I'll be more than happy to help.
 
OP
fade2black

fade2black

Member
Joined
Mar 7, 2002
Location
NE Ohio
Well, I need to get past step one first and that's getting both boxes to see each other. Dave was given to me, so I don't argue with free!

I just don't like macs because I don't understand them. I have always networked PC's and Macs make no sense to me, that's all :)

- Fade
 

rugby

King of Cats Senior
Joined
Feb 2, 2001
Location
Chicago, IL
I think the exact opposite way. I've networked Macs for years now and when I throw a windows box on the network I have to walk through it like it's the first time every time. To me, Macs make sense with their networking.

What OS are you running on your Mac? Are your subnets identical with identical gateway addresses (probably are since you can access the internet, but it doesn't hurt to check)
 
OP
fade2black

fade2black

Member
Joined
Mar 7, 2002
Location
NE Ohio
It's running OS X and OS 9.2 (I'm sure you know how it runs both since you are obviously a Mac user:) ) They are both on the same subnet and I use DHCP from my router, although I have tried static IP's with the same results. I just don't understand why I can't get a ping reply from the 2k box to the G4. I'm just pinging it through the terminal in OS X. I'll give Apple one thing...OS X is sweet because it is based on the Unix kernel. That helped me understand a lot more than I would have otherwise! :D

- Fade
 

rugby

King of Cats Senior
Joined
Feb 2, 2001
Location
Chicago, IL
Yeah, I'm learning so much unix stuff also! Here's a quick and dirty way to share files, On the Mac, click on system prefs, sharing, file and web tab, and click on the button that says Allow ftp access.

Bam, instant ftp server. Users log in and see their home directories. Slick.

THe amount of stuff you can do with OS X is fantastic. I have my home directory on a separate partition from my OS just in case the OS gets hosed from one of many apps I beta test. Here's a good book, Mac OS X Unleashed, it's fantastic for OS X stuff. It starts at the newbie level and gets deeper into CLI stuff.
If you need any OS X info feel free to email me and I will send you a bunch of stuff.
 
OP
fade2black

fade2black

Member
Joined
Mar 7, 2002
Location
NE Ohio
OK, I have found that the 2k box won't reply to pings from anything, the mac or the router. My Internet works fine, and I can ping the mac and the router from the 2k box. Any ideas why it doesn't reply to pings or allow ANY connections (tried telnet and ftp). I'm assuming all the right services are running because everything else works ok. I went through the services list and anything that has to do with networking is running.
 
OP
fade2black

fade2black

Member
Joined
Mar 7, 2002
Location
NE Ohio
I use zonealarm, but I turned it off and tested...same problem. Still nothing. Actually the firewall was my first idea because I used to get alert messages when someone tried to ping my address, so I changed the internal network to lower security so I could ping (per Zonealarm's tech support). I had the same problem so I just turned it off and still nothing. I have a feeling the problem is a service not running, but this installation is only about 3 weeks old, and I haven't really changed anything (that I can remember).
 

Wonko The Sane

Member
Joined
Dec 16, 2001
Location
Port Richey, FL
I was just looking through my 2K machines services list, and didn't see anything that may be causing this (then again, I don't know what a lot of those do). try completely uninstalling the firewall software. there may still be a part of it running.