• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Windows 10 - Connecting to WiFi and Ethernet Simultaneously

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.


May 9, 2011
Alberta, Canada
I've recently upgraded from Windows 7 to 10 on my main rig. It wasn't a light decision, but more and more developers are dropping support for Win 7 and I figured 10 has had sufficient time to have a lot of bugs ironed out. For the most part it's been a smooth transition, but when it comes to networking I'm having a peculiar issue...

In Windows 7, I was able to connect using both an Ethernet and WiFi connection. The Ethernet is connected to my ISP provided modem/router and the WiFi is connected to a second router that's behind the modem/router. I realize the issues with double NAT, but my ISP router doesn't afford me as much control as the other router...

Under Windows 7, my Internet traffic would go through the Ethernet and my local traffic between computers goes through the WiFi.

Since upgrading to Windows 10, Windows refuses to automatically connect to my WiFi network. It's like it sees that it has an Ethernet connection and just gives up on connecting to WiFi even though I have told it to connect automatically.

I've tried searching online for solutions but haven't really been able to find anyone with my specific problem. Nothing I've tried has worked so far. I've tried changing the WLAN AutoConfig service in services.msc with no luck. I've given WiFi higher priority in connection settings, but that isn't maintained on reboot (the Ethernet connections are shifted to the top again).

Any suggestions/information would be greatly appreciated. Thanks.


Jul 9, 2001
Louisville, KY
Not sure what you are doing with your local traffic but can you set your ISP modem/router to passthrough mode so its just acting as a modem then just use your router?


New Member
Dec 4, 2011
Satan's Colon, US
I have the same problem with a friend's Win 8.1. It won't connect to Ethernet and wifi simultaneously. I'll be following this one.


Premium Member
Feb 1, 2011
Republic of Texas
Just for giggles, try deleting the IP address and disabling the hardware aspect, i.e., turn it off. Reboot and reinitialize the hardware, see what happens.