• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Windows to Samba issue

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

coin

Member
Joined
Jan 6, 2003
Location
Denmark
I finally managed to get Samba set up to display the relevant shares to a Windows workgroup so far so good.... I can easily access the share available to all and do whatever takes my fancy. The problem arises when I try to acces any of the controllde shares. I have created a matching account with matching password on the RedHat box bu whenever I try to connect to the shares I get the request for login box, not a problem but the user section has assumed the 'guest' user on my Samba box and has greyed over the box so that I cant change it. Now there is no 'guest' account on the Redhat box and I am loathe to create one as it makes controlling share ownership far harder. Does anyone know how to stop XP's assumption of a guest account?:mad:
 

klingens

Member
Joined
Apr 3, 2002
Location
Xanadu
Are you logged in as a user with your Windows XP?
WinXP was the first windows ever which let me chose the name under which I got my samba shares. It defaults to my username, but lets me edit it if I want to. nothing special required
 
OP
coin

coin

Member
Joined
Jan 6, 2003
Location
Denmark
Titan:
sorry should have phrased it better, the Linux (red hat 9) box is working as my Smaba server. I'm trying to connect to the published shares from the XP box. The issue being that if I try to connect to any share that has some form of access restriction it wont allow me to log on as anyone except \\Hostname\guest.

klingens:
Yes, I'm logged into XP with my usual account and for once I can't pink who I log onto another machine as :(
 
OP
coin

coin

Member
Joined
Jan 6, 2003
Location
Denmark
This is my current smb.conf file. I'm sure I'm missing something obvious it's just that I've been trying to get this to work for so long I can't see the wood for the trees.

#======================= Global Settings
[global]


null passwords = yes
workgroup = ROOM3B
server string = filestore
hosts allow = 192.168.0.
load printers = yes
log file = /var/log/samba.%m
max log size = 50
security = share
encrypt passwords = yes
ssl CA certDir = /etc/ssl/certs
socket options = TCP_NODELAY
interfaces = 192.168.0.50
dns proxy =no

#============================ Share Definitions

;[homes]
; comment = Home Directories
; browseable = no
; writable = yes

[printers]
comment = All Printers
path = /var/spool/samba
browseable = no
guest ok = no
writable =no
printable = yes

[public]
comment = Public Storage
path = /store
public = yes
only guest = yes
writable = yes
printable =no

[private]
comment = Nic's Files
path = /store/personal
guest ok = no
read only = no
username = @mort
 

Titan386

Senior Member
Joined
Jun 8, 2002
Have you created the user @mort on the Red Hat box, and set its password with smbpasswd? Make sure that the username and password match those of the user on XP that you want to be able to access the shares.

I'm not too familar with the way XP connects to shares, but that's all I've had to do in the past to get it working.
 

Titan386

Senior Member
Joined
Jun 8, 2002
snowmobile74 said:
just creating a user on the linux box is not enough you must allso add it to the samba users list

I assume you refer to the smbpasswd file?

Running smbpasswd, as root and with the -a option, will add the specified user to the smbpasswd file. Besides existing in /etc/passwd, the user in question does not need to be in any other files. Look at the smbpasswd man page if you're interested in the details.