• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

WinXP defaults to PIO4 instead of UDMA/100

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

Luggage

New Member
Joined
Nov 17, 2002
Location
Jerrmanay
I'm frustrated. Both my hard disks support ATA/100 mode, the mobo does, and the cables do. Still WinXP refuses to run in DMA mode, and defaults to PIO mode 4, which is like 1/8th the transfer speed and drains CPU time like hell.

Running WinXP pro, ePox 8K3A mobo, tried both CSEL and Master/Slave jumpering to no effect, tried installing latest 4in1's, no effect, tried installing IDE Miniport driver, that broke something so I had to reinstall WinXP... tried BIOS upgrade, turned out I already had the latest one.

I've checked the ViaArena forums too, and there are quite a few people with the same problem, but none of them had found a solution. So... does anyone know a way to get me running smooth again?
(Oh yeah, I think this worked right when I still had Win98, but I'm not sure, and I won't downgrade just to check.)

Cheers, hope you can help

Lugg
 

Captain Slug

Helpful Senior Member
Joined
May 23, 2001
Location
Asteroid B-612
Are you using rounded cables?
Have you rechecked your IDE settings in your BIOS?

A CD-ROM drive I have would not use DMA in windows until I set it up in the BIOS first and selected a mode.

Otherwise you may want to compact epox about know issues or quick fixes.

I know alot of people here with the 8k3a and I'll try to hunt them down for you...
 

cmcquistion

IT Director Senior
Joined
Oct 15, 2001
Location
Tennessee
I've heard of this issue before, here in the forums. It's quite common and is caused by overclocking. If WinXP detects problems with the hard drive, it lowers the speed. It can detect these problems if the PCI speed is way out of whack.

There is a workaround. Search the forums and you will find it.
 
OP
L

Luggage

New Member
Joined
Nov 17, 2002
Location
Jerrmanay
Alright...
I'm using rounded cables, but I just bought those because it didn't work with my flat ones either. There's no overclocking at work here btw.

I'll hunt in the forums for a bit :)
If it's caused by my PCI speed, is there a way I can adjust that? :-/

Cheers, Lugg
 
OP
L

Luggage

New Member
Joined
Nov 17, 2002
Location
Jerrmanay
Yeah, I tried that, to no effect :(

I contacted some epox support dude, and they said I should deinstall the Via 4in1s 0_o
I found that registry hack workaround, but it didn't work... I have to try it again though, after regediting the reboot went smooth as butter. Then WinEksPee detected new hardware, had me reboot, and was as slow as before.