• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Year 2024 and Logitech STILL can't make a good piece of software to support it's devices

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.


New Member
Jun 18, 2012
This is soooo F-ing frustrating to say the LEAST!

I happily own (and with NO INTENTION to throw out perfectly good products) the following from Logitech:

  • Logitech G19S Keyboard
  • Logitech G502HERO Mouse
  • Logitech G922 Artemis Headset
THEY ALL WORK PEFECTLY. - What doesn't. BOTH Logitech gaming Software (V 9.04.49) AND Logitech Ghub (latest version as of May 11, 2024)

I really hope someone can help because it seems the entire internet has moved on from this chronic issue which remains unresolved to this day for many other users. Here's the issue many are still suffering from.

- Install Logitech gaming Software (V 9.04.49) and it detects ALL devices BUT!!! - the DPI on the mouse just will not work and YES, I tried setting it to onboard memory. It STILL will not work. the lights work, greeeaaaaat.
- Install Logitech Ghub (latest version as of May 11, 2024) and it detects and runs perfectly the mouse and headset BUT! - Will not detect the Logitech G19S Keyboard.

So I'm left having to choose between one or the other depending on what features I can and can't live without.

Can someone PLEASE help! My stuff works but is being actively "undetected" on purpose, is the feeling I'm getting just to force me to upgrade.

I uninstalled GHUB (useless) and sticking with Logitech gaming Software (V 9.04.49) for now until I can figure this out.

Last edited:

HOLY - F! - I never thought I'd be able to fix this on a Windows 11 machine. Here is what I did. Keep in mind this is in 2024 as all other fixes are VERY outdated.

  1. Stick with Logitech gaming Software (V 9.04.49)
  2. Locate Lcore.exe (usually found in C:\Program Files\Logitech Gaming Software)
  3. Right click Lcore.exe and click "properties"
  4. Click the "Compatibility" tab
  5. Make sure "run as Administrator" is checked
  6. Click "Change High DPI Settings"
  7. Make sure there is a check in "Override high DPI scaling behavior"
  8. Under that, choose "Application" and OK your way back to Desktop
  9. Reboot PC
  10. Once PC is fully booted and running open up the Logitech Gaming Software
  11. Choose your mouse and in the Home screen for the mouse make sure you select "On-Board Memory" and click on the GEAR ICON WITH THE ARROW
  12. Play around with either the "Assign Default" or "Assign Shift" to "jumpstart" your DPI into working again WITH the lights.
  13. DONE! you can now customize and set your DPI settings and they WILL work.
This is how I was able to fix it on a Windows 11 machine so give it a shot and please let us all know how you did so we can help others

Last edited: