• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

SOLVED Bad power supply??

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

occamsblade

Registered
Joined
Oct 2, 2019
I have a Corsair rm1000x. I recently disassembled my entire computer did some maintenance on my liquid cooling and put everything back together. After doing this I started the computer up and it did the typical start restart thing for the first couple of seconds then it ran perfectly fine. After using it for about an hour to an hour and a half with no issues I shut it down. When I returned and attempted to turn it back on, nothing happened when I hit the switch. When I say nothing I mean nothing. No fans, no LEDs coming on, no nothing. The only thing that appeared to be functioning where the strix motherboard lights that were on before I hit the switch and stay on as long as the power supply is on. I remove the 24 pin connector as well as pretty much everything else from the power supply and tested the power supply using the paperclip method. It passed this test. I was able to run a few fans as well as some of my LEDs that do not get controled by the motherboard.

Initially I thought the issue may have been the case switch, so I bypassed that on the motherboard. Still absolutely no response. I then switched out motherboards. And I am still having the exact same issue. I have tried disconnecting everything that is not necessary to get the board to post. The initial motherboard was a ROG strix z390 gaming, the one I am using as a backup / test motherboard is a Asus TUF z390. I needed the ports for my liquid cooling to line up, so I had to stick with the same series.

Thoughts? Suggestions?