• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Sudden Triple Monitor Issue - The display settings could not be saved

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

Gerb68

New Member
Joined
Feb 21, 2016
I have been running a Triple monitor setup for at least 3 years now and all of a sudden one of the monitors will not connect. Whenever I try to 'Extend desktop to this display' I get the error 'The display settings could not be saved. Please try a different combination of display settings.'

The triple monitor config I now have is DVI+DVI+DisplayPort-DVI active adapter.
Is there a fix or workaround for this? I have tried everything I could think of, I re-installed AMD drivers. Reset resolutions on Desktop displays.
I have also tried DVI+HDMI+DisplayPort-DVI active adapter but it now seems that my ATI Radeon HD 5850 driver will not extend to a 3rd monitor. I am using an Accell B087B-001B UltraAV Display Port/DVI-D adapter

I cant understand how all 3 displays worked perfectly for a couple of years then suddenly stopped.

The Display port adapter works when only using 1 screen.
With DVI + DVI + DP to DVI connected. Only DVI + DVI work.
with DVI + DP to DVI connected. DVI + DP to DVI both work.
with DVI(the other DVI port) + DP to DVI connected DVI + DP to DVI both work.

Then it gets weird. When I connect all 3 monitors and switch around which monitor is connected to which connector (i.e. either of the DVIs and the display port) only 2 monitors work but there is a randomness as to which 2 of the 3 monitors work.


I am unsure as to what to do next. At this point I would also like to know what is the root cause of this issue so that I can go about replacing any problem hardware i.e. Is it the graphics card etc?
 

ATMINSIDE

Sim Racing Aficionado Co-Owner
Joined
Jun 28, 2012
Do all three monitors work if you run them separately?

Have you tried a clean driver install?
 
OP
G

Gerb68

New Member
Joined
Feb 21, 2016
When tested on their own each monitor works perfectly when connected to each of the ports (Display port, HDMI and both DVI connectors).

I have also tried everything with the video driver. Uninstalled, reinstalled, rolled backup to old drivers.

When this issue began I was using a StartTech display port active adapter http://www.amazon.com/StarTech-com-DP2DVIS-DisplayPort-Active-Adapter/dp/B004SUO1GM.

Thinking this was the cause I recently purchased an Accell B087B-001B UltraAV Display Port/DVI-D adapter http://www.amazon.com/Accell-B087B-001B-UltraAV-DisplayPort-Passive/dp/B001CXXD2Q.

So I doubt its the display port adapter at fault.
 

ATMINSIDE

Sim Racing Aficionado Co-Owner
Joined
Jun 28, 2012
Eyefinity requires an active adapter, can you buy a new active adapter?

After that I'd say the next step is to try a different GPU. The 5850's have been around a while, it may just be giving up the ghost.
What brand/model is it? Some came (IIRC) with a lifetime warranty, you might be able to approach the manufacturer about troubleshooting and possible replacement options.