• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

SOLVED Dell H310 (IT firmware) with Debian Linux?

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

HankB

Member
Joined
Jan 27, 2011
Location
Beautiful Sunny Winfield
Anything special I need to do for this? The HBA shows up in lspci:
Code:
01:00.0 Serial Attached SCSI controller: LSI Logic / Symbios Logic SAS2008 PCI-Express Fusion-MPT SAS-2 [Falcon] (rev 03)
        Subsystem: Dell 6Gbps SAS HBA Adapter
        Flags: bus master, fast devsel, latency 0, IRQ 16
        I/O ports at c000 [size=256]
        Memory at fb3b0000 (64-bit, non-prefetchable) [size=64K]
        Memory at fb3c0000 (64-bit, non-prefetchable) [size=256K]
        Expansion ROM at fb400000 [disabled] [size=1M]
        Capabilities: [50] Power Management version 3
        Capabilities: [68] Express Endpoint, MSI 00
        Capabilities: [d0] Vital Product Data
        Capabilities: [a8] MSI: Enable- Count=1/1 Maskable- 64bit+
        Capabilities: [c0] MSI-X: Enable+ Count=15 Masked-
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [138] Power Budgeting <?>
        Kernel driver in use: mpt3sas
        Kernel modules: mpt3sas

At present I have one drive connected and it does not show up - I think it should be /dev/sdc since a-c are drives on the motherboard SATA connectors.

lspci shows a driver so I'm not sure what else is needed.

Thanks!

Edit: It seems that the problem is the drives. They are 200GB Seagate Barracudas:
Code:
=== START OF INFORMATION SECTION ===
Model Family:     Seagate Barracuda 7200.7 and 7200.7 Plus
Device Model:     ST3200822AS
Serial Number:    3LJ39YHJ
Firmware Version: 3.01
User Capacity:    200,049,647,616 bytes [200 GB]
Sector Size:      512 bytes logical/physical
Device is:        In smartctl database [for details use: -P show]
ATA Version is:   ATA/ATAPI-6 T13/1410D revision 2
Local Time is:    Wed Jan  3 09:36:21 2018 CST
SMART support is: Available - device has SMART capability.
SMART support is: Enabled

All other drives I have tried (all more modern) have worked with this HBA. I'm speculating that the barracudas take to long to reply when the HBA queries them. This drive works fine connected to a motherboard SATA port.
 
Last edited: