• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

M.2 not working but recognized by BIOS

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

timesavage

Member
Joined
Mar 7, 2011
Location
Bay Area
Hey group, it has been a while. I just purchased a Samsung M.2 950 to try and use as a boot drive. I have tried everything, UEFI bootable jump drive, download F6 drivers, unplugged everything. When I was unsuccessful with all of that, I decided to try and just use it as a standard drive. I could not find it in disk management, i downloaded RST and could not locate it there as well. It is being identified in the BIOS. I am open to all suggestions, and i have researched a bunch of solutions on both sides of this issue. Thanks for the help

I dont know if my signature updated yet but I have a Z270 Hero, i7 7700k and corsair dom @ 3000
 

notarat

Member
Joined
Nov 11, 2010
I had an issue similar to this with an 8TB HGST Mechanical drive. I installed 3 of them and the first two were fine while the 3rd had nothing but issues.

It showed in BIOS fine but Windows refused to recognize it. After futzing around with it for the better part of 2 days on and off, swapping around drives, I finally got it to show up in Disk Manager.

In my case I found out after the fact that the chipset used for connecting the third one (the Asmedia chipset) could not see the drive in its unformatted state. When I plugged in a previously-formatted 8TB drive into the Asmedia chipset and plugged the unformatted "problem" drive into the Intel Chipset, both were recognized fine and have worked fine ever since...

Hang in there, you'll get it resolved.
 

EarthDog

Gulper Nozzle Co-Owner
Joined
Dec 15, 2008
Location
Buckeyes!
Does it show up in computer management->disk managment? You may need to I utilize the drive before it shows up in 'this pc' in windows.
 
OP
T

timesavage

Member
Joined
Mar 7, 2011
Location
Bay Area
So I thought the F6 rapid storage drivers were what I was looking for. JrClocker, you were right, I just needed to download the Samsung drivers. This solved my problem with the disk showing up in disk management. As for creating a boot drive with the M.2, no luck. I think I tried almost everything, for which I think i might be doing a few steps wrong (i.e. creating a UEFI boot drive on a flash drive). Due to my massive amount of frustration with this, I am taking a short break. Thanks for the help. My OS is Windows 7, it probably works better with windows 10
 

bikerkip

Registered
Joined
Feb 8, 2017
Location
Smyrna, TN
Since you have an ASUS board you might need to make some BIOS changes.........These are the steps I had to follow to get my 960 evo drive setup for Boot....Your UEFI will look somewhat different from my ASUS Z170 BIOS but close enough that you should be able to get it going....



1 - Make sure you unplug all SATA and USB drives, the M.2 drive has to be the only drive installed.

2 - Go into the bios, under the boot tab there is an option for CSM, make sure it is disabled.

3 - Click on secure boot option below and make sure it is set to other OS, Not windows UEFI.

4 - Click on key management and clear secure boot keys.

5 - Insert a USB memory stick with a UEFI bootable iso of Windows 10 on it, USB3 is quicker but USB2 works also. A Windows DVD won’t work unless you’ve created your own UEFI Bootable DVD.

6 - Press F10 to save, exit and reboot.

7 - Windows will now start installing to your NVME drive as it has its own NVME driver built in, I don't think this would work with previous versions.

8 - When the PC reboots hit F2 to go back into the BIOS, you will see under boot priority that windows boot manager now lists your NVME drive.

9 - Click on secure boot again but now set it to WIndows UEFI mode.

10 - Click on key management and install default secure boot keys

11 - Press F10 to save and exit and windows will finish the install.

Once you have Windows up and running, shutdown the PC and reconnect your other SATA drives. Do not put anything on SATA port 1 as this is now reserved for the NVME drive.

I would also recommend installing the Samsung NVME driver at this point to replace the Windows one.

The background here is NVME SSDs do not appear within the BIOS until Windows creates the system partition with the EFI Boot Sector.

Your M.2 SSD contains UEFI driver information within the firmware. By disabling the CSM module Windows will read and utilize the M.2-specific UEFI driver.