• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

S6 Active will not connect to my PC

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

BlueNostromo

Member
Joined
Mar 24, 2015
My phone will not show up on my computer at all. It used to quite a while ago. MTP and USB debugging are both selected on my phone. All autoplay options are set to prompt me for action on my computer. My cables work perfectly fine and I have tried multiple. I have tried reinstalling the Samsung Drivers multiple times. No change. I am at a loss to why.
 

hokiealumnus

Water Cooled Moderator
Joined
Oct 14, 2007
Just to ensure it's nothing simple, when you plug it in, are you pulling down the notification panel on the phone and telling it to connect to the computer? On Marshmallow, the default action (on the phone) when plugged in is charge only. You have to tell it to connect to the computer for file transfers if that's what you're trying to do.
 
OP
BlueNostromo

BlueNostromo

Member
Joined
Mar 24, 2015
Just to ensure it's nothing simple, when you plug it in, are you pulling down the notification panel on the phone and telling it to connect to the computer? On Marshmallow, the default action (on the phone) when plugged in is charge only. You have to tell it to connect to the computer for file transfers if that's what you're trying to do.

I do not know what you are talking about. There is no option to change anything.

- - - Updated - - -

Just use wifi file explorer pro. Then no cables are ever needed for any pc.

I have been looking for something like this. Thank you!
 

knoober

Member
Joined
Mar 18, 2015
I do not know what you are talking about. There is no option to change anything.

Seems like the wifi thingie might have you covered but just in case.... The path used to be Settings > PC Connetion (or connect to PC....specific name was different on different devices) > choose between charge only/Media transfer/camera mode

On my device with Android 6.0 (marshmallow) I have to go to Settings >Developer Options (sometimes this option is hidden unless you do a specific set of steps. Google for your device if it is not enabled by default. I have never seen a version of android without a way to enable Developer Options)...boy that was a long side comment .... Settings > Developer Options > Select USB Configuration > Charging/MTP/PTP/RNDIS/Audio Source/MIDI .They really beefed up the options. I dont know if those options are device specific or available to all Marshmallow users though. It is certain that you will have Charging/MTP/PTP or some variation of the three to choose from though. Choose MTP :D
 

hokiealumnus

Water Cooled Moderator
Joined
Oct 14, 2007
I do not know what you are talking about. There is no option to change anything.
After you plug the phone into the PC, there should be a non-dismissable notification. Pull down the notification panel and it will probably say something to the effect of 'Charging only'. Touch that and it will present you with options to connect as a media device for file transfer, connect as a camera, etc. Select for file transfer and the PC should then display the phone as a drive on your PC.
 

TechWizard

Member
Joined
Nov 16, 2004
You probably need Kies.

http://www.samsung.com/in/support/usefulsoftware/KIES/

You don't need it to use the software suite - just for the driver portion it installs. After it installs you should be able to access your device like any flash drive or ext hard drive plugged into Windows.

I have the S5 Active and I needed the Kies drivers when flashing/modding my OS, before that I couldn't get a connection either.