• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Excavated a Shuttle, what can I do with it?

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

mackerel

Member
Joined
Mar 7, 2008
I can't remember what I was looking for exactly, but I unearthed an old Shuttle computer if anyone still remembers them. Arguably they were the first small form factor systems, with mobos comparable to mini-ITX long before that even existed.

Anyway, I got one, will it run? There's a PSU hanging off the side. I remember the original had died, and I replaced with a similar one from a different model I had spare, but it wasn't a directly mechanical replacement. Plugged everything in, and it booted. Nothing on the hard disk, which I could see was a WD of some sort. Ok. I saw a spare ribbon cable and connected up an old Plextor CD writer. Anyone remember Plextor? Am I sounding old now?

Anyway, couldn't find and old XP CD, but did find a Win2k one. That'll do. It booted and I went to start the install. USB keyboard wasn't recognised. Went and found a PS2 one, which allowed me to go through the setup. This was before the days of quick format, but thankfully the disks in those days were small enough not to take long to do a full write, and not much after I booted to Win2k desktop, in 640x480 in 16 colours. Yuck!

Surprisingly networking worked straight away and I went to Google in IE. What version of IE was it? 6? No, 5! Google still worked. I went to CPU-Z to try and identify the hardware, but the website couldn't be navigated. WCPUID did download and run, showing a 1 GHz Pentium 3 with 256MB of 133 MHz CL2 SDRAM. If memory serves me right, 133 CL2 was high end in its day. Yes, it was a very long time ago!

It also identified the, I can't call it a GPU, the video chip as a S3 Savage 4. S3? Remember them? I found a driver on S3's website but it wouldn't install.

Ok, let's see if Shuttle still exist, and they do. But what model is it? Couldn't see any external model. The mobo did allow me to identify the system as the SV24, and find its download page. I got the drivers and am about to try installing those.

A fun part of all this is since I couldn't use IE5 at 640x480 16 colours, I was using my ancient Nexus 7 tablet to look up things as I went along. That's probably more powerful!

Almost bed time here so after the driver I'll try and do more tomorrow before writing. Will also have to get some photos.
 

saturn

Disabled
Joined
Dec 31, 2015
Pc133 cl2 was good.
Pc142, Pc150 and pc166 was the highend stuff.

As for the s3 card, make sure you have the right driver. There are a lot of s3 savage model.

Also there are a lot of s3 drives here.
http://www.vogonsdrivers.com/index.php?catid=26

For usb keyboard support, your need to enable that in the bios.

You will need a newer web browser to use most sites and the newest version of cpuz will not work on 2k without mdding 2k abit. Try oldapps.
 
OP
mackerel

mackerel

Member
Joined
Mar 7, 2008
Drivers installed ok now. The one I downloaded from Shuttle worked where the one from S3 didn't, and I am fairly sure I got the right model in there. I haven't poked around the bios much yet, but wonder if I can get more vram. It uses 8MB currently which is enough for 1024x768 at 24-bit colours, or 1280x1024 (monitor native resolution) at only 16 bit.

SPD of ram reports it supports 142 CL3 so that might be something to see if I can get working later. I don't actually recall seeing beyond 133 used, unless it came out later by which time we were on 1st gen DDR.

Upgrading to IE6 now. I tried to grab chrome but couldn't even access the page for it. Seriously doubt it would run either. Would Firefox be more retro-compatible? Latest CPU-Z worked fine.
 

saturn

Disabled
Joined
Dec 31, 2015
I would use Firefox.
As for the ram. Anything over pc142 was not common and rare in oem system. To this day it's still hard to find. Keep in mind you had to over locked the system for the ram to run at said speeds.
 
Last edited:
OP
mackerel

mackerel

Member
Joined
Mar 7, 2008
I should add I bought this system used so what's in it might not have started in there. Time for a quick play before going to work...
 
OP
mackerel

mackerel

Member
Joined
Mar 7, 2008
Had to give up on the Win2k install as I couldn't do anything useful with it.

Decided to try making this box into something useful. Discussed with guy at work pfsense, so could play with that. I've added an old 3com gigabit PCI network card. It will never reach gigabit over PCI, but it doesn't have to since my internet is only 50mb/s anyway. There's only 1 expansion slot so the other end will be the mobo LAN connection. Looking at the minimum specs I think I will make it. Ram is just on minimum. I also dug out an old 2.5" IDE laptop drive to connect to the mobo. Could do with scanning it for bad sectors as it hasn't been used in ages, and I have no idea what state it was in when I last used it.

I've rehoused this into a more conventional case as I don't have the PCI riser to leave it in the Shuttle case. Because I recycled the fan controller elsewhere the CPU fan is now an ear splitting 4000rpm and I'll need to drop that for actual use. I wonder if I can replace the tiny heatsink with something a bit better but I have no idea what I can dig out for this era. I have found a Taisol heatsink/fan which looks like this one: http://www.anandtech.com/show/662/10 so it should be compatible if there is enough clearance around the CPU socket. Will be a job for tomorrow.

I've taken some photos of rehousing it into the new case, but this will have to wait until I bother extracting it from my phone.
 
OP
mackerel

mackerel

Member
Joined
Mar 7, 2008


Not the best pic but gives a taste. Case is a more modern micro-atx one which I don't like as it is a bit cramped for micro-atx, but this Shuttle mobo is mini-itx ball park and has plenty of space inside.

What I don't have space for is the Taisol cooler. There is no room on 3 sides of the CPU socket. I have found another heatsink that is bigger than the Shuttle one without going outside the socket, but the clip is missing and I'm not sure if I can find a way to mount it. I'll keep looking in the bits in and see what else I might dig up. Another option might be to use the Taisol fan on the Shuttle heatsink as from memory they were slower so would be quieter.

Oh, no backplate here. The holes were cut directly into the Shuttle case.
 
OP
mackerel

mackerel

Member
Joined
Mar 7, 2008
@mods, could this be moved to the home projects forum? Seems to be a better fit with where I'm going...

I kept digging and found a selection of heatsinks and clips, but nothing matched with anything else. After running out of options I put the original back on with some fresh thermal compound. I managed to find a resistor fan cable so hopefully that'll be enough to make the noise sane.

Next step I want to scan the hard disk, then I can start the install of pfsense.