• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Genius Gila Game Mouse & Windows 10 Help

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

BoundByBlood

Maybe Something Cool?
Joined
Sep 27, 2009
Location
MS Gulf Coast
Hello everyone.

I have been having a bit of an issue with a new gaming mouse so maybe someone out there can give me a bit of insight on how to resolve it. I'm going to give some history of the issues with some of the things I have tried to resolve it and I'm really going to do my best to summarize while still conveying the major points. I promise.

Back in my Windows 7 days I used to have a Genius Death Knight mouse which I loved and kept until it just wouldn't work anymore. I didn't know much about the Chinese manufacturer Genius at the time, but what drew me in to the Death Knight was the button placement for its programmable macro buttons and I felt it was a pretty intuitive design. Turned out to be a great peripheral device and one of the best gaming mice - particularly for MMOs - I had used. Not too long Genius put out an evolved version of my beloved DK mouse, the GX-Gila, which is essentially the same mouse with an additional three extra mouse buttons. When I had an opportunity a week ago to pick up the Gila for super cheap I jumped on it.

This is the Gila -
genius gila.jpeg

This mouse has 8 programmable macro buttons:
M1 & M2 on the LMB
M3 & M4 on the RMB - [mouse wheel tilt left and right by default]
M5 & M6 below the DPI toggle - [media volume up and down by default]
M7 & M8 on the left side - [mouse buttons 4 and 5 / buttons X1 and X2 by default]

The problem is the software to control the mouse is designed for Windows 7 / 8 and doesn't work with 10...at all. The mouse operates as a standard HID compliant mouse in Win10, but I can't program any of the macro buttons or control the lights. I have tried everything to get this software to work including updating the firmware and still nothing works. If someone asks I will gladly go into detail and state the troubleshooting steps I took.

The software simply will not with Windows 10, probably never will, so I have accepted it and given up on even trying to pull a miracle out of a hat anymore.

This is when I start thinking out the box about third party software solutions and I have tried most of the popular applications I see people talking about in forums, but none - not even the commercial ones - have been able to take control of all 8 of the macro buttons. Some software suites do better than others and in the end they all still manage to fail.

X-Mouse Button Control? Only recognizes M7 & M8 as X1 & X2. I looked into creating a script in AHK which has a call sign for every mouse button except M1 & M2 on LMB. On the commercial side there was one program, ATNSOFT's Key Remapper, which had come close like AHK, but it still had not recognized M1 or M2 either.

Apparently M1 & M2 are non-standard mouse buttons which do not have any predefined functions in windows so in these various apps when I click those two mouse buttons nothing happens. Every other macro button will light up a specific value / function that the software can take control of and bind except for the first two. The software is treating these two buttons as non-existent so if a predefined function doesn't exist any value cannot be attributed to it - so the apps say - which just makes these apps treat the buttons as not being "real".

However, I know they are real because even though the official outdated and unsupported Genius software didn't work I still browsed through it and the M1 & M2 buttons did have an option for binding just like all the other ones. I know these buttons are programmable, it's just a trick of getting some third party software to recognize all 8.

In the end it's not a huge deal because if I can't make the Gila work the way I want then I will break down and get something else I know that will work, but I'm not ready to give up on the Gila yet. It's a nice mouse, I just want to be able to take control of all of the buttons including M1 & M2.

I'm open to all feedback, suggestions, and ideas.
 

Amiva

New Member
Joined
Nov 23, 2017
Sorry, your question I have never encountered and I do not know what happened to your mouse failure, so can not have a help to you, this trouble is too difficult, maybe you can go to a professional computer repair shop consult a computer expert.
 

bob4933

Member
Joined
Jan 3, 2014
Sorry, your question I have never encountered and I do not know what happened to your mouse failure, so can not have a help to you, this trouble is too difficult, maybe you can go to a professional computer repair shop consult a computer expert.

Just because you don't know the answer doesn't mean others dont lol.


@op -> The drivers arent going to work if they dont have windows 10 drivers to install with.

What you can do, remove whatever drivers you do have, enable "Generic usb device" drivers (what happens when you just plug a mouse in). From there you should be able to use this program
http://www.highrez.co.uk/downloads/XMouseButtonControl.htm

and basically remap the mouse to other keys with mouse 4/5/etc functions.
 

Amiva

New Member
Joined
Nov 23, 2017
I already understand this problem, and learn a lot of knowledge about the mouse, which is really helpful to me, thank you.