• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

invisible floppy drive

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

Phugbox

Member
Joined
Dec 20, 2001
Location
Toronto
I have no regular floppy connected, windows still insists on listing the a: as being present and accounted for, even when there's not drive in and it's indicated not installed in bios.

and for some reason when I plug in my usb floppy drive it get's assigned b:, however, it doesn't show up in my computer. I accidentally hit b: once and lo and behold there it was.

how do I fix this up

it's windows xp
 

Permanoob

Member
Joined
Feb 27, 2004
Location
SLC, UT
my bad.. There's 2 places in BIOS where XP might be picking it up. On your BIOS make sure there's nothing listed on the first screen for floppy drive and again, make sure the floppy controller is disabled. I used to have the A7N8X and that's all I can think of that would be alerting XP to a floppy drive. If those two options are disabled then my only thoughts areis that XP is possessed and you need Catholic help.. STAT.

(small exorcism joke)
 

kct2

Member
Joined
Feb 20, 2002
There is a difference between the 'Main' screen in the bios showing there is no floppy installed and the controller being disabled on the 'Integrated Peripherals' page. Make sure the "Floppy Disk Access Controller" is set to disabled, in addition to "Legacy Diskette A:" being set to disabled.

Kaso said:
meh, I'd just use the Hide FDD from OS setting in my bios, but i guess yours doesn't have that

That feature was included for use with Windows 95 only. Windows 95 would not boot if a floppy drive was not installed, so that special settings was required to use 95 on a computer with no floppy. The option has mostly gone away along with the use of win95.
 
OP
Phugbox

Phugbox

Member
Joined
Dec 20, 2001
Location
Toronto
sadly I don't know what my options are anymore.
I have both fdd channels set to not installed
floppy seek is disabled, just about and in fact everything directly flopy related in bios is installed. but the worst part is that, my usb floppy drive does NOT show up under my computer, I have to manually type in b: to get the drive, and anything looking for a floppy drive just looks at me saying "what? I see a floppy drive, what areyou talking about, it's a: oh but I can't write there, something's wrong, cna't read there either"