• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

SSD's randomly take turns disappearing, need to reboot to get them back...

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

Pepi93

Member
Joined
Jul 12, 2002
As the title says, I've had some random disappearing of my SSD's.

I have 3 in my rig and I'm sure it has happened to all 3, including my OS, which is probably why I've been BSOD'ing...PC would somewhat stop responding and I get a critical termination error f4 with no driver at fault according to bluescreen viewer. I don't have the file anymore so I can't post the info.

It's completely random and infrequent and it started recently for no reason. I originally suspected my old OCZ was giving up after years of service so I disconnected it but then it happened to my Samsung Evo's also...

Here's what I've tried so far...

1) clean installs
2) using only motherboard qualified drivers as well as up to date motherboard drivers from intel (separate installs)
3) new SATA cables
4) switching SATA ports on the mobo, although I'm not done this part of the test yet. I'm now using port 1 for my bluray drive, 2,3,4,5 for my SSD's and one spinner.

I've been doing some reading and apparently it's a very common symptom and something with bios switching SATA port 0 and 1 etc...which is why I took my drives off the 0-1 ports.

Now I have no idea what to but I have some questions...

1) my mobo has 6 intel SATA ports numbered 0-5, do I need to plug my OS drive into port 0? I don't believe so but I wanted to check.
2) I recently bought a 980ti and it's huge with a backplate. The card pretty much covers and sits almost flush with the SATA ports. I'm honestly not sure if it's maybe touching the SATA ports...hard to tell....Could the GPU be causing some kind of electrical short on the SATA ports? My SATA cables have the metal clips but after today's SSD disappearing on me I put the cables with clips in behind and I use the all plastic SATA cables in front (which would be closest to the gpu HS)

I didn't change any BIOS settings and so I'm left with thinking the SATA ports might be giving up on my mobo but then why would it work in the first place?

I can do anything I want, play games etc...

Any help or additional insight would be appreciated

My rig is in my sig

Thanks.
 

Mr.Scott

Beamed Me Up!
Joined
Jun 9, 2013
It is a board issue.
Gigabyte has known about it for a while. They tried fixing with bios updates.
Things to try:
Disable the Marvell controller and try the Intel ports again.
Switch to the Marvell ports and try those.
If neither works out for you, you'll need another board.
 
OP
Pepi93

Pepi93

Member
Joined
Jul 12, 2002
My board is 3 years old, isn't it weird that it would start to happen now?

I've never used the marvel ports and I don't have the drivers installed...should I try them as you suggest?
 

Mr.Scott

Beamed Me Up!
Joined
Jun 9, 2013
My board is 3 years old, isn't it weird that it would start to happen now?

I've never used the marvel ports and I don't have the drivers installed...should I try them as you suggest?
Electronics are weird.
Trying them won't hurt.
You'll never find the issue if you don't try something. :)
 
OP
Pepi93

Pepi93

Member
Joined
Jul 12, 2002
Ok I'll wait till the next disappearance since I made some adjustments this morning...

Is this issue with current boards too? I've been eyeing the z170 boards from gigabyte...
 

Mr.Scott

Beamed Me Up!
Joined
Jun 9, 2013
Not as far as I know.
It was limited to a few Gigabyte models of Z87 and Z97.
 
OP
Pepi93

Pepi93

Member
Joined
Jul 12, 2002
I haven't figured this out yet and it happened again but took almost a week to trigger...

I'm now using a marvel SATA port for my bluray drive and took my drives off the 0/1 intel SATA ports

I'm still curious if this could in any way be a conflict with my huge GPU? The fact that it's so close to the SATA ports.

I read that SATA ports don't usually start to malfunction after 3 years unless there is corrosion etc...

I also thought that maybe constant plugging/removing usb sticks into the front I/O panel could be somehow causing this especially if the usb's are not top grade?

Any additional help would be appreciated...
 
OP
Pepi93

Pepi93

Member
Joined
Jul 12, 2002
I don't want to speak too soon but I think I may have found the culprit.

Xbox 360 controller. Two things..one, the driver is not necessary, windows has it's own already which works fine. Secondly, when plugged directly into the PC usb ports, this error of drives disappearing is triggered at random times. I have since plugged my xbox controller into my monitor's usb hub and haven't had the issue since.

I also ended up installing Windows 10 and that seems to have fixed other issues too.
 

satrow

Member
Joined
Feb 20, 2015
Location
Cymru
Nice troubleshooting.

Sounds feasible, iirc, older W7 drivers for the Xbox 360 controller were dodgy enough to trigger BSODs and other oddities, mostly fixed by the latest driver versions. MS should have taken note of that for W10 and incorporated a stable driver.