• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Unable to get 5.1 Sound any longer

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

Wolverine690

Member
Joined
Jun 7, 2006
Location
Idaho
I'd been using an old Sound Blaster X-Fi Titanium Fatal1ty Professional series sound card for years with no issues. Then for whatever reason it just stopped. The speakers were fine (logitech Z906) I tested them on other devices. 2.1 Channel works fine with it, just when ever I try to play 5.1 in games it's only doing 2.0. I've go the game set accordingly and had it set in windows and the software as 5.1. When doing the configure in windows the pings only are audible for the front and left channels nothing else including the sub go off. I've uninstalled and reinstalled drivers a million times with no luck.

I also reloaded my pc I got other new hardware and thought ok maybe a driver issue and a fresh install would work things out but no luck still same issue. I ended up getting some other new hardware and also just wanted to change some things around and so I did another reload of my windows (this is over a 3 month period). Again still not able to get my 5.1 to work. I thought ok maybe the card just died on me partially for that feature.

I just got a new Sound Blaster Z AE-5 Plus card now and installed it and still having the same issue... Again I've uninstalled and reinstalled drivers with still no change. It's doing the same exact thing. I'm at my wits end with this. I know Creative has a history of some buggy drivers and I've never had this much trouble.

Anyone have any ideas?

Thanks
 

EarthDog

Gulper Nozzle Co-Owner
Joined
Dec 15, 2008
Location
Buckeyes!
Actually, forget it. I see you said you confirmed the speakers (all/5.1) work outside of this system. My fault. :chair:

That said, if you can get it working through the same OS and using the integrated audio, it does isolate the card/driver environment as the source.
 

Zerileous

Senior Member
Joined
Jun 21, 2002
I think someone else was just having problems with a SB driver. Could this have coincided with a driver update? Can you try an older driver?