• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

XFX RX480 8GB VBIOS Problem

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

minstmeatz

New Member
Joined
Feb 12, 2021
So I purchased an RX 480 understanding that it was for parts or not working off of Ebay figuring I could fix the issue with it. Well I'm not able to and I've spent hours trying to reflash bios's any which way I can with my current pc. I've tried all of the stock XFX bios/roms out of the TechPowerUp Library. I am unable to get the cmd prompt to work that comes with ATIflash. It force closes without error on the first or second command entered. I've tried using a usb drive and it isn't recognized by the mobo bios/UEFI. I've gone to the extent of trying all of this with a complete ddu wipe and running just iGPU on my 10850K. The 480 was in slot one and my other card was out of the system. I also removed all of the GPU overclocks along with any XMP profiles. I didn't go to the extent of CMOS reset by removing the battery.

The card had an odd MSI vbios on it in the master slot for the switch. I attempted to flash it with the correct vbios off of TPU getting "subsystem id mismatch" everytime. When I decided to try reflashing the MSI vbios it was successful, but locked up the pc immediately after, and now I get a blackscreen with a white underscore offcenter before even getting to my bios/uefi screen. In the second vbios position it has the same MSI rom/image/whatever flashed and I'm able to load windows and log in for about 30 seconds before it blue screen crashes and the issue is reported as "Thread stuck in device". I can mitigate this by disabling the 480 in device manager. It is recognized as a 480 8gb as soon as it is connected. Fans do spin-up on boot up as well, but quit quite quickly after. The card hovers in the mid/upper 60's at idle in Task Manager. I've looked the PCB over while it was apart and there are no noticeable problems with burnt caps or oil leakage. Reapplied thermal paste after cleaning off remnants that were all over the card. Thermal pads, although stacked two high, are in good condition and not torn. I did see that the card had obviously been apart because the void stickers on the heatsink screws were poked through, and fairly fresh thermal paste and pads were in between the card and heatsink.

I've attempted the 1+8 or 1+5 pin# jump on the vbios chips on the back of the card to try to get it to actually boot on the master side of the switch, but that is absolute chaos in the computer I've built. It also just seems to force restart my pc and that cannot be good on things. Sketchy sparky nonsense here. Lucky I didn't destroy something.

I'm out of ideas, but I'm fairly certain it is a Vbios issue. I've seen there are manual ways to flash vbios's to the chip with a special clip, but I wanted to see if there are other ideas to try before spending more money on it. I also have not tried older drivers for the 480. I've just downloaded the newest version of Adrenaline and figured that would suffice.



Current build (if it matters)

Win10 Pro 20H2

MSI Z490 w/ 10850K cooled by a ArcticFreezer 280

Gskill ripjaws 16gb single stick/channel 3200mhz (oops)

500gb m.2 Crucial P2

750w coolermaster masterwatt semimodular psu

3060TI I way over paid for