• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Xfxf 7970 DD Black edition black screen

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

dangerouSoul

Member
Joined
Aug 13, 2015
Location
Portugal
Hi guys i had a weird day yesterday.
My pc was running fine yesterday. I was in youtube and then boommmm.. I got black screen and a weird noise. After that my pc won´t boot into OS. I always got the vga red led on on my mobo. I don´t know if the gpu broke or what.. When i turn on pc it beeps as usual but i get no signal from my tv. However with integrated hd graphics and my gpu disconnected i can go to safe boot. And once in awhile i can enter OS perfectly. Maybe corrupted files on OS or a broke gpu???
Appreciated some help please.. Yesterday was my birthday.. What a f****** day...........
Windows 10 64bit
If you guys need more info please tell me.
 

EarthDog

Gulper Nozzle Co-Owner
Joined
Dec 15, 2008
Location
Buckeyes!
You can try to...

Test the GPU in another PCIe slot.
Test the GPU in another PC.
Try another GPU to make sure the PCIe slot still works.
 
OP
D

dangerouSoul

Member
Joined
Aug 13, 2015
Location
Portugal
You can try to...

Test the GPU in another PCIe slot.
Test the GPU in another PC.
Try another GPU to make sure the PCIe slot still works.

I tried in another pcie slot with no luck.
I´ll try later on my uncle´s pc.
I have to ask a gpu from a friend to test the pcie slot..

Thanks man =)
 
OP
D

dangerouSoul

Member
Joined
Aug 13, 2015
Location
Portugal
You can try to...

Test the GPU in another PCIe slot.
Test the GPU in another PC.
Try another GPU to make sure the PCIe slot still works.

I swaped my gpu and it works. My gpu gave up on me =(.. The fans still spin when i power on pc.. Is there anything i can do to bring it to life??
 
OP
D

dangerouSoul

Member
Joined
Aug 13, 2015
Location
Portugal