• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

ASUS p8p67 rev 1 SATA and (or?) Memory problems

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

borro

New Member
Joined
Sep 26, 2012
ASUS p8p67 rev 1 SATA and Patriot PSD34G1332 Memory problems

I seem to have some serious problems with my rig :cry:

I build up this system January this year (2012) and it worked very very okay for about 6 months. If the system runs it runs like a dream :) But since a while (2 to 3 months) I've been experiencing 2 serious problems.
I am at a loss..:confused:... searched the net high and low and cannot find any reference to either of my issues. This is a first in my many years of tweaking that this is the case....:bang head

I'm aware I need to perform more testing for problem 2 (move Ram around) but since I wanted to post the first issue I felt I had to also mention the second since in IT everything can be related :). I will move the Ram around soon, hard to find time in between work, family, private projects etc etc.

Below you'll find:
  1. Problem 1 - SATA RAID setup slow, HDD's continue to rev up and down.
  2. Problem 2 - BSOD memory problem, Windows Search related?
  3. System setup
  4. System use
  5. Questions / my own thoughts

Thanks for reading and hopefully for helping me troubleshoot, any pointers to useful references are of course also welcome.
If it helps to upload dumps for the BSOD's let me know.
And if I ask a complete NOOB question (one is always afraid to do so :p) please let me know kindly :D!

1. Problem 1. SATA RAID setup slow, HDD's continue to rev up and down.
My RAID disks (1 or more?) keep on spinning up and down. I hear them revving up and then a click (head moving or parking?) and revving down and again, sequence takes about 30 seconds.
I haven't been able to determine a pattern in when and why it happens. It starts sometime after startup (sometimes after 5 minutes, sometimes after up to 30 minutes). Sometimes it continues all evening, sometimes stops every once in a while. It does not seem to be triggered by either much or little disk activity (while heavy image editing it sometimes happens, sometimes it doesn't).
When the disks are in this state (rev up and down) data access on the RAID disks sometimes lags (pause for 10+ seconds when accessing or saving files).
The 2Tb disk does not seem to be affected and using data of that works just fine, no lag whatsoever.

Tried so far:
  • Search the net for similar issues: nothing found.
  • Bought a replacement disk (the Seagate) since one of the 4 original Samsungs showed a health of 95% in Hard disk sentinel. Moved this Seagate around the array (i.e. replaced each 100% good Samsung as well) but had no effect, problem still cames up.
  • Put all SATA ports in BIOS to Hot swap enabled, no effect, problem still comes up.

2. Problem 2 - BSOD memory problem, Windows Search related?
I have irregular BSOD's occuring. When I run Windows Search approx once a day my system crashes. When I turn of / kill Windows Search through uninstall it via Control Panel the BSOD's occur a lot more intermittent, my feeling is roughly every other week when continuously running (no shutdown but stand by when not used).

Whocrashed shows a lot of ntkernel (i.e. memory error type). Also one ATI driver error, but have updated this driver to be sure and haven't seen that again.

Tried so far
  • Checked out the BIOS CL settings, it turned out the auto setting (the board sets) sat at CL 9-9-9-24 whilst Patriot info says it should be CL 9-9-9-26. So manually set BIOS at CL 9-9-9-26, did not help.
  • I've ran Windows memory diagnostics: no errors
  • I've ran Memtest86+ the other day. Had to start it up via clicking on it in the bios, no direct boot when set boot priority to "UEFI: Card USB...." first. Only works when I click "Card USB......" (without UEFI: in front) in boot page of bios, it then goes directly to Memtest86+ without passing a full boot sequence again.
  • Within seconds the first 500+ errors appear, after another minute the counter jumps to 5000+ errors, stopped after that since I either have a LOT of errors or Memtest86+ does not startup correctly (see previous point)

3. System setup
CPU
  • i7-2600k – standard clock 3.4Ghz
MOBO
  • Asus p8p67 Rev B version 1 (i.e. revision B3, built after recall of early 2011)
  • Latest bios version 3509
MEM
  • 16Gb DDR3 1333 Mhz (PC3-10600)
  • 4x 4Gb Patriot PSD34G1332
  • CL 9-9-9-26 (manual override in BIOS, auto was set at 9-9-9-24)
OS
  • Windows 7 64x ultimate
  • All mobo drivers (and other drivers) fully up to date (double checked)
HDD - OS (pure OS and program files, NO userdata such as desktop,
  • downloads, mail etc.)
  • 120 Gb SSD OCZ Vertex 3 SATA600
  • Connected to 1x Intel SATA600 port
  • 9 months old (jan 2012)
HDD – DATA
  • 3x 750 Gb Samsung HD753J 7200 rpm
  • 1x 750 Gb Seagate 7200 rpm
  • Connected to 4x Intel SATA300 ports
  • Set up in Raid 10 (1,5 TB effective storage)
  • Samsung Roughly 5 years old (2007), Seagate brand new
HDD – MEDIA
  • 1x 2Tb Seagate Barracuda Green 5900 rpm SATA600
  • connected to 1x Intel SATA600 port
  • 9 months old (jan 2012)
DVD - DVD burner
  • SATA, Connected to Marvell SATA600 port
VIDEO
  • ATI Radeon 4870 GPU, 1Gb mem
POWER
  • Corsair hx620 Watts PSU
MONITOR
  • 24" 1920x1280

4. System use
I use the system mainly for heavy raw image editing (photoshop, photomatix, lightroom).
Next to that some video watching / editing, office use, programming, very occasional game (GT4 was the last I played for a prolonged period) and general home use.

5. Questions / my thoughts
  • Could this be related?
  • Could I just have the luck to have bought a monday morning built board?
  • The SATA issue sounds like the issue early 2011 Intel had with the p67 (degradation after time)? But I do have the B3 revision p67
  • The memory errors in Memtest86+ seem to start coming to fast to me (within seconds the first appear), and since I have to start it directly from bios (i.e. full boot cycle does not work) could it be it starts up incorrectly?
  • What would be the best / suggested course of action: Buy a new board, contac ASUS support, move Ram around to test for memory issue, buy new memory first or or or?

Once again thanks for reading and thinking along,
Bor
 
Last edited:

fornoob

Member
Joined
Jan 10, 2012
Location
clean room-grenoble (france)
Hello Borro, welcome here! :)

Woww, nice presentation, thanks for the job, it would be so nice if everyone was doing the same effort to detail their issues o_O


I will do my best to answer you as clearly and accurately as possible:

1. I didn't find your Patriot RAM reference in the QVL of your motherboard
http://www.asus.com/Motherboards/Intel_Socket_1155/P8P67/#MSL

It doesn't mean that it is a compatibility issue in EVERY case: really often, the system boot even with a RAM that doesn't figure in the spec of the MB.
Sometimes compatibility label isn't given because of an issue in a very particular configuration that only 1% of the customer will ever use (like RAID 10, I personnaly use RAID 5 ;) )

In all RAID configuration, your RAM will come into action so both problems could come from your RAM.
Check also the compatibility of your HDD (especially the Samsung who sounds to me to be old Hitachi's... who were know to be the source of a lot of trouble in RAID 10).

2. No :D


It isn't the same fun, the same feeling of paternity ;)
To avoid troubles with the motherboard, I avoid ASUS the best as I can ^^' (10 MB bought, only 1 was working correctly... I don't want to generalize my case, but some things start to be annoying after some time xD ).

3. The chipset and SATA controller seems to work fine since you have no issues with other HDD.
It sounds more like a compatibility issue to me. Maybe a test of the SATA port by switching "healthy" drives with the more problematic HDDs?
Always better to be sure that the problem doesn't come from it.

4. Same thing: could be explained by a compatibility issue. Starting a RAID with the wrong RAM is a good way to get massive amount of error :)

5. I would start to try an other set of ram (figuring in the QVL of the P8P67). See what is coming.
Then I would check every single HDD (moving away one, testing the others in each SATA port, then again and again...).
Be also really carefull using different speed HDDs in a configuration where a RAID array is built: the RAID controller often understand a "significantly lower" speed as an unplugged or dead HDD. It can destroy a RAID array if the faulty HDD is used in the array.

No reason to change the MB right now!

I hope it will help you!
 
OP
B

borro

New Member
Joined
Sep 26, 2012
Hi Fornoob,

Thanks so much for taking the time to read about my problem and composing a reply to my questions!!! :clap:. I started to think my input was perhaps too extensive and scared people off ;)

I did make some progress since my first post but I'll first:

Reply to your input:


Re - Patriot memory not in QVL:

Correct, and apologies, I knew but forgot to mention this. At the time I bought the MB and memory at the same shop and it never occurred to me to double check whether the memory was supported. Since my problems I of course did and found it's not mentioned in the QVL.

Re - Raid 10 vs. Raid 5
I have good reason for using Raid 10 :) Being an enthusiast amateur photographer I use my machine mainly for picture processing and work with large raw files and large photo collections. So I opted for raid 10 because of the performance aspect.

Re - RAM in action with Raid
Thanks for this input, I wasn't aware of this. I always assumed that the SATA controller handled all Raid aspects and it does not require RAM activities. Probably I'm mixing up SCSI and SATA workings.

Re - HDD compatibility
I did look for HDD QVL for the MB but couldn't find anything. I also searched for Samsung HDD input on this but also couldn't find anything there.
However: I have used these disks (they are indeed a bit older: 2008) in the same Raid setup since purchase. Until January of this year they were attached to a Gigabyte p35 MB (i.e. previous generation Intel Sata Raid controller). All those years they have worked flawlessly so I do not have any leads why they would not work properly on a newer generation Intel Sata Raid controller.

Re - Asus MB quality
That is useful insight (whilst realizing this is indeed a personal experience and does not necessarily apply to all).
Before buying I did of course research and ended up with the p8p67 board because of price and feature set, but also because of reviews and experiences. I did not find many complaints about Asus quality so at the time figured it would be a good choice.
Your suggestion will make me think again if I ever end up with Asus after research again.

Re - Sata controller seems to work fine
Since my post I did fool around with the HDD setup. As mentioned I replaced one 95% health disk with a new one. Subsequently I moved the disks around over the various Sata ports. I found that the problem kept recurring in 4 different variations, but only once I filled the disks with data (1Tb+). I stopped there as this testing is a cumbersome process that takes hours (moving disks, initialize raid setup, copy files from backup). My conclusion was (also taking into account the disks have been working properly in the exact same setup for years on an Intel controller) that I do have a Sata controller issue.
Also I haven't been able to point it at one HDD, HD Sentinel shows a 100% health for all, comparable error etc. counts across all, surface tests all went through without errors.

Re - I would start replacing RAM
Darn I received your advice too late; I started the other way around as you can read below ;-)

Progress since first post
What I've done since my first post in chronological order:

  1. As said above I first moved HDD's and rebuild the Raid setup. This had no effect; error (long lags when accessing data) kept coming back.
  2. I posted the exact same problem description as above with Asus support. Within a day I received a reply stating my MB was probably faulty and I should return it to my supplier for testing and possibly repair. MB, Mem and CPU were bought with one supplier, other items such as case, HDD's, SSD, DVD, Video, Power were either already in my possession or purchased elsewhere. So it would mean I had to dismantle my PC completely and only send back parts. This for me was not an option since I cannot (or do not want to) do without my PC for weeks.
  3. I then pursued to replace the MB (considering my HDD moving findings plus the fact that the Sata problem was way more blocking for me then the BSOD problem).
  4. Did some research and went for an Asrock Z77 Extreme4 board. An upgrade from p67 to z77 since I did find some stories about p67 B3 version MB's also showing the over time Sata degradation issue. Asrock Extreme4 because of features, price and reviews/experiences.
  5. Removed all p8p67 drivers from windows 7 I could find
  6. Built up the hardware again keeping the SSD with OS the same (i.e. not re-install windows).
  7. Was able to miraculously re-activate OEM windows 7 via phone activation (and Office 2010 as well)
  8. Installed all p77 drivers
  9. Fixed all driver errors I could find
  10. Checked all programs (Photoshop, Lightroom, Office, Outlook etc.) and that all worked.
  11. Create Raid in same setup as before
  12. Moved all data from backup

Experiences so far

  • Had one BSOD whilst rebuilding but that was before I installed all z77 drivers.
  • Since then the machine has been running Sunday evening October 7th onwards without BSOD. It probably has been running for some 30 odd hours and the other time has spent on standby.
  • System works perfect again: Office, Outlook, Photoshop, Lightroom now all start within one second (as it should having an SSD), Windows boot up time is 24 seconds or under, from pushing power button to desktop under 45 seconds. Haven't seen it being this fast for a while.
  • My Sata problem seems to have been solved, HDD's work perfect, no lag experienced so far, no revving up / down heard yet. (Whereas I was able to recreate the problem moving the HDD's around on the old board within 3 hours).
  • OC-ed CPU to a conservative 4.2 GHz (using standard Asrock settings, fooling around comes later) Tuesday the 9th of October. It seems to run fine on that so far.
  • Memory problems still arise:
    • Performed Memtest86+ and it still gives countless errors. I stopped after running 1 pass for 10% and had 40.000 plus errors.
    • No BSOD's till yesterday evening. But then I turned on Windows Search (see input in first post on Windows search probably causing most BSOD's). Only 1 hour after I've done that I had a BSOD. Played around (turning on and off) and it seems that Windows Search is still causing BSOD's.

So current status / next steps:
  • Raid / HDD problems seem to be fixed with the new board :attn:
  • Memory problem still arises :bang head

My next step is to replace the RAM as you suggested :p
I've ordered 16 GB’s of new RAM which this time is mentioned in the Asrock QVL lists. This should arrive today / tomorrow.

I'll of course keep you posted on the outcome after I've fiddled around in the weekend.

And once I've fixed it I'll have to see if I can get my supplier to replace the MB and Mem under warranty (or refund money). Replacement will also be fine since I can then upgrade my shed web / data / backup server ;)
 
Last edited:

EarthDog

Gulper Nozzle Co-Owner
Joined
Dec 15, 2008
Location
Buckeyes!
QVL list simply means they tested it to work. It does not imply or mean that it is not compatible.

Did you verify that you have set the timings and voltages properly for the ram? DL CPUz and post screenshots of the Memory and SPD tab with one of your sticks selected... and see if it matches. If not, change it to match and try memtest86 again. :)

PS - B3 versions of boards do not have the SATA issue. That was earlier, non B3 revs (B3 was to FIX that problem).

PPS - HDD is a HDD is a HDD. There are no compatibility issues with any HDD on boards, now PCIe SSD is another story, but that isnt what we are talking about.
 

fornoob

Member
Joined
Jan 10, 2012
Location
clean room-grenoble (france)
Hey!

You know, it takes me less time to read a well detailled report like yours than to try to complete/ guess/ interpret a low detailled one :D

I have just a question: did you load the XMP profile of your RAM or did you just plug in the sticks?
I ask that because if you don't load yourself the XMP profiles, the RAM settings will be set by default and default settings are... awful? ^^'
Other trick to do is to make sure no dust stays in the RAM slots. You just bought a new one so it shouldn't be an issue :) (nice choice indeed, Asrock MB are surprisingly good and reliable).


Concerning Asus, I won't throw them the rock (don't know if this expression exists in english ^^') because like you said, it is personnal experience and I was particularly unlucky.
I have tested Asus MB (the MB of one of my PC is an ASUS ROG, the only one who did work at first try xD) and they are really good!... when it works ^^'
I stopped buying these MB only because I don't feel comfortable when buying something begins to look like russian roulette :D
So, it was the story of my life, let's end with this :p

Just ckeck for the XMP profile and you should be fine!

EDIT: There is no HDD compatibility issue with MB nor RAID. Some HDD are just known for encountering issues in RAID array after long period of time/ or heavy use. The hitachi's are one of them essentially because they are the most common one so those with the most feedback :)

EDIT2: hi Earthdog! Sry for telling almost same things as you, I didn't see your post while writing :)
 
Last edited:
OP
B

borro

New Member
Joined
Sep 26, 2012
Gentlemen,

Thank very much for your replies!

I'm now delving into the Mem settings a bit deeper. My sticks are not XMP so that is no option.

On the z77 MB all was still set to auto which resulted in 9-9-9-24, CMD rate 2N and 1.5 volts.
Already knew it had to be 9-9-9-26 (tried that on the P67 board) but did not see CMD rate and voltage yet. Also found tWR, tRFC, tRRD, tWTR, tRTP, and tFAW settings (from others HWINFO logs)
Changed all that (the additional values were also way of), pc runs fine (for now :)), correct values show up in both CPU-z and SIW and now about to to start Memtest86+ again.

I'll let u know.

EDIT: p.s. Regarding the p67 B3 having Sata degradation issues: I am aware about B3 being the fix for the original issues. Thats why I mentioned. I did come across one tale about a p67 B3 having Sata degradation issues.
 

EarthDog

Gulper Nozzle Co-Owner
Joined
Dec 15, 2008
Location
Buckeyes!
Your sticks do not have an XMP profile? Can you post a screenshot of the SPD tab (Host it here at teh site not 3rd party)?
 
OP
B

borro

New Member
Joined
Sep 26, 2012
Aparently no XMP indeed :-/. I couldn't find any reference online and here's an excerpt with the memory part from my CPU-Z html report created just now:

DIMM # 3
SMBus address 0x52
Memory type DDR3
Module format UDIMM
Manufacturer (ID) Patriot Memory (7F7F7F7F7F020000)
Size 4096 MBytes
Max bandwidth PC3-10700 (667 MHz)
Part number PSD34G13332
Number of banks 8
Nominal Voltage 1.50 Volts
EPP no
XMP no
AMP no
JEDEC timings table CL-tRCD-tRP-tRAS-tRC @ frequency
JEDEC #1 6.0-6-6-17-23 @ 457 MHz
JEDEC #2 7.0-7-7-20-27 @ 533 MHz
JEDEC #3 8.0-8-8-22-30 @ 609 MHz
JEDEC #4 9.0-9-9-25-34 @ 685 MHz


EDIT: and now with current CPU-Z screenshots attached (but I couldn't find any XMP reference or am I blind? ;)).
 

Attachments

  • cpu-z-spd-3banks.jpg
    cpu-z-spd-3banks.jpg
    37.7 KB · Views: 353
  • cpu-z-memory-3banks.jpg
    cpu-z-memory-3banks.jpg
    30.9 KB · Views: 335
Last edited:
OP
B

borro

New Member
Joined
Sep 26, 2012
But anyways:
I expect to have fixed it! :D

Started to move the RAM around and test and found the culprit for the memory problems. One of the banks generated errors in Memtest86+ (thousands within 10% of the first pass), the other three made over 1 pass without any errors.

So now am running on 3 banks (12Gb) for the moment and see how that goes. And soon let memtest run overnight. But considering the first memtest results I have good hopes.

And then of course also return the MB and faulty bank to my supplier.

Thanks so much for your help :thup:. I learned quite some new stuff (didn't know Ram and Raid were interacting, didn't know what XMP was before, didn't have the correct settings for my memory etc) and my machine is working again!

I'll let you know in a week or so how it went (or sooner if its not fixed :D)