• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

Windows 10 ASUS X-99 and ASRock USB 3.1 Front Panel problems.

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

wade7575

Registered
Joined
Feb 9, 2016
I have and ASUS X99-A Mobo and a ASRock USB 3.1 Front Panel and I'm running Windows 10 64 Bit Home,the hard drive case's I'm using are Vantec USB 3.1 with SanDisk Extreme and SamSung 850 Pro SSD's in them.

After installing the ASRock Front Panel my PC ran great for about 3 weeks to a month,first it would just Blue Screen of Death on me once and then I would not have any problems for 3 or 4 days then it would BSOD again then start happening more and more until it's an every time thing,and a lot of times if it does not BSOD it will lock up my mouse witch is plugged into the rear panel of my PC and then BSOD when you unplug the case.


At first I thought ok it's just a problem with Windows 10 and did a reformat but the same thing started happening again,the first thing I tried when it started happening again was a system restore from a restore point I had created but that did not help either the thing that happened there was I wasted my time.

I wonder if I would have these problems if I went back to Win 7 because if it's a Win 10 problem MS sure isn't to quick at fixing the bug's in this OS although they just did a major release not so long ago.
 

EarthDog

Gulper Nozzle Co-Owner
Joined
Dec 15, 2008
Location
Buckeyes!
I doubt its a Windows issue.

Have you tried installing all the USB drivers from your motherboard website? Have you tried each SSD alone? BTW, Vantec 3.1 doesn't tell us anything. Which Vantec HDD enclosure do you have?
 

JrClocker

AKA: JrMiyagi
Joined
Sep 25, 2015
I also doubt it's a Windows 10 issue.

Do you have an overclock on your CPU?

Have you checked your memory? Are you overclocking your memory?

I agree it could be a driver issue. Have you installed all of the MB drivers from the website?
 
OP
W

wade7575

Registered
Joined
Feb 9, 2016
I have updated all of my drivers from the ASUS site and I was running this PC for 4 months or more with no problems until I started using the Vantec case's and the ASRock Front Panel with no problems at all.

Here is a link to the Vantec case's and my Ram is on the approved vendors list.

http://www.vantecusa.com/en/product/view_detail/667
 

EarthDog

Gulper Nozzle Co-Owner
Joined
Dec 15, 2008
Location
Buckeyes!
At this point, I suggest removing one item at a time and see if the problem stops (either the Vantec storage enclosures - I wouldn't call them a case - or the FP USB3.1 device). Currently, we do not know if it is the Vantec enclosure (is there 1 or more? You say "case's" but not sure if that was meant to be plural or what... you have an apostrophe in there - shows ownership, not plurality - which confuses me) or the front panel USB that may be causing issues when its used.

Does this happen when the Vantec enclosures are NOT plugged in?
 
OP
W

wade7575

Registered
Joined
Feb 9, 2016
I have 4 of the Vantec enclosures,the front panel is plug and play from what I understand because it did not come with a driver cd and worked right from the start.

I have another front panel not sure of the brand I think it's a Syba and it is USB 3.0 and I do not have any problems if I plug the Vantec enclosures into it,I'm not sure what the deal is because the Vantec enclosures and the front panel are both using Asmedia controllers.

This does not happen when the Vantec enclosures are plugged in only when I plug them in.
 
Last edited:

EarthDog

Gulper Nozzle Co-Owner
Joined
Dec 15, 2008
Location
Buckeyes!
Sounds as though that asrock front usb isn't playing nice with those Vantec enclosures.if they work on the other syba one, plug them in there and the others in the asrock...
 
OP
W

wade7575

Registered
Joined
Feb 9, 2016
I guess I should give Vantec a call and let them know and hopefully they will look into this and make changes if needed,I can only hope that ASUS hurry's up and gets their USB 3.1 front panel out soon.
 
OP
W

wade7575

Registered
Joined
Feb 9, 2016
Now it's gotten to point I can not plug in any of my USB 3.1 enclosures into my PC whether it be threw USB 3.1 3.0 or 2.0 I really hate these idiot companies that never seem to agree on anything,I know the 2 Reps at Vantec told me that one problem is there is no real protocol for USB 3.1.What really sucks is now I do not have any other options other then try the ASUS Front Panel or send back the enclosures if they are the problem and hope that they make the right change's.

I did call Vantec and they said the chipset in their enclosure and the ASRock Front Panel should work very well together and the guy I talked to thinks it may have more to do with an update on my PC but who really knows at this point.

I'd like to try an ASUS Front Panel and that's what I wanted all along but the problem is they are more concerned with releasing to Europe first before the States and Canada and ASUS does not know when they will be releasing it over here so that's great news as well.

I'm supposed to call the guy back at Vantec and I will update this thread once I have more info.
 
Last edited:
OP
W

wade7575

Registered
Joined
Feb 9, 2016
I just got done doing some messing around to see if I could narrow down for sure what is the real problem I'm having and I have narrowed it down to the SSD drives and using them with the USB 3.1 port no matter how they are hooked up.

As I said before in other post's in this thread I was using the SSD drives in Vantec enclosures that are USB 3.1 and I got thinking I have a generic brand USB 3.0 enclosure I got off of ebay and have owned about 5 of them and gotten many for friends as well and never a problem with them,so I got thinking why not try an SSD drive in one of them while hooked up to USB 3.1 and the same result another BSOD right away,I pull out the SSD and put a 500GB SamSung mechanical drive in and it works just fine with the generic case no problems at all when hooked to my ASRock USB 3.1 Front Panel.

The next thing I tried was putting the SamSung 500GB mechanical drive into the Vantec USB 3.1 enclosure and no BSOD not really sure what this means,not sure if it's a combo of the Vantec case's and the SSD's or if it's something to do with the Front Panel or if it's something to do with the Mobo.
 
Last edited:

ATMINSIDE

Sim Racing Aficionado Co-Owner
Joined
Jun 28, 2012
Have you tried with the rear ports instead of the front ports?
 
OP
W

wade7575

Registered
Joined
Feb 9, 2016
Not yet but that would be a good idea,I will try tomorrow and see what happens.

I also got a friend of mine from Italy to get me a ASUS USB 3.1 Front Panel and is going to ship it o me that is the Front Panel I wanted all along as I use more stuff with A Type plug's.

Have you tried with the rear ports instead of the front ports?
 

trents

Senior Member
Joined
Dec 27, 2008
Typical problems found with a new USB standard. USB has always had it's share of issues and particularly in the early stages of a new standard when it comes out. And if its a plug and play driver built into Windows you can just about put money on it that Microsoft will send an update to the driver that will bork the device.
 
OP
W

wade7575

Registered
Joined
Feb 9, 2016
I just tried plugging in a Vantec enclosure with an SSD into the back USB 3.0 ports on my PC and the same thing happens BSOD.

I starting to lean more towards it's a problem when an SSD is hooked up to the PC because that's the only time it does it never when a normal HDD in a Vantec USB 3.1 just with an SSD,I'm also wondering if the ASRock Panel is part of the problem as I had to use a USB 3.0 cable with a header that goes onto the Mobo and a USB 2.0 on the end so the panel could power,not sure why ASRock did it this way instead of the way ASUS did it where you only need power from a power supply line.
 
OP
W

wade7575

Registered
Joined
Feb 9, 2016
Well my post before this one can get scratched because now the Vantec USB 3.1 enclosure and mechanical HDD are now causing my system to BSOD.
 

ATMINSIDE

Sim Racing Aficionado Co-Owner
Joined
Jun 28, 2012
Do the drives cause issues when connected directly to the motherboard's SATA ports?
 
OP
W

wade7575

Registered
Joined
Feb 9, 2016
I have a SandDisk 240 GB Extreme in my PC for a Main drive and it seems to work fine and it was purchased at the same time as the ones I put in enclosures.

I seen on ASUS's site that they have a ASMedia Firmware updating tool for the Front Panel whether is used as a Front Panel or a Card that goes into a PCI slot,when you update the firmware on something like this it flash's the chip with new firmware and once it's done it's done and there is no need to re-flash it if reformat on the PC is needed correct.

I'm hoping it's just a firmware update is all it needs when I get the ASUS one and that will end this crap.

Do the drives cause issues when connected directly to the motherboard's SATA ports?
 

EarthDog

Gulper Nozzle Co-Owner
Joined
Dec 15, 2008
Location
Buckeyes!
He didn't ask if that drive works, he asked if the drives you are having problems with work when connected to SATA. This will tell you if its the drives or the connectivity causing the issue. ;)
 
OP
W

wade7575

Registered
Joined
Feb 9, 2016
I just got done trying all my SSD's in my PC and it runs fine with them in it.