• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

wbk38 clip broke my socket, but only after broke my duron :(((

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

fog

Registered
Joined
Jan 20, 2001
my sockets 2 of the plastic "things" that hold the clip are broken, someone can help me to figure out other way to attach the wbk38?
i have a7v133, please kind people helP!
 

UnseenMenace

UnseenModerator
Joined
Apr 23, 2001
I would suggest trying to locate a old unwanted or dead mobo and cutting the plastic lugs from the socket from that and trying to re-join them to your socket using epoxy resin or another composite glue

or

bond a nylon nut to the mobo and modify the 'clip' so that it screws down tight.

Theres a few suggestions from me, dunno if any would work though
 

ken257

Senior Member
Joined
Dec 20, 2000
The best thing you could do is get a cooler like the Swiftech that bolts down using the 4 holes in the mobo. You can't beat the spring loaded bolts and it makes it almost impossible to kill a cpu with this setup.

You could try super glue to put the tab back on but can this realy be trusted? What if your PC need to be trasported? And the globalwin's clip is very strong to boot.
 
OP
F

fog

Registered
Joined
Jan 20, 2001
i gusse i should get the Swiftech MC 462-A ,
where can i buy it thou ?

i'm sure that the glue wont hold anything on..
 
E

el

Guest
you could get teh golden socket thing too! i don't know how much or where to get it. just do a google search and you will find it. For those how don't know it is a multiplier unlocker slocket that fits into your 462 and has new latches on it. might solve the problem cleanly and if you haven't done the L1's you would have it unlocked too!