• Welcome to Overclockers Forums! Join us to reply in threads, receive reduced ads, and to customize your site experience!

dma mode in ata/atapi devies in windows xp

Overclockers is supported by our readers. When you click a link to make a purchase, we may earn a commission. Learn More.

Bilal

Registered
Joined
Aug 23, 2003
Location
New Jersey
i have a tdk burner. It doesnt burn correctly. Its like, it reads for a second or two, stops reading for several seconds, then starts again for a second or two...nothing really burns. APparently, after calling tdk, they said that xp is being the problem. It switched the drives in that channel to PIO mode, while they SHOULD be in DMA mode. How do i go about changing the modes back-to DMA?
 

deeman

Member
Joined
Apr 27, 2003
first i would check your bios and make sure it is enabled there then go to controlpanel>performance and maintenance>system>hardware tab>device manager>ide ata/atapi controllers then go to properties for primary or secondary which ever one it is connected to then go to the advanced tab and change to Dma if available and restart
 

repo man11

Member
Joined
Dec 28, 2001
What has worked for me is to uninstall the IDE controller that the drive is connected to, and reboot. I had to that recently because for some reason my DVDROM was in PIO mode, rather than UDMA like it should have been.

I uninstalled the IDE controller, rebooted, it detected and installed the controller, rebooted again, and the DVDROM was in UDMA mode as it should have been. No more hesitation when playing music CD's